<!doctype html>
<html  lang="en-US">
<head>	
	
<meta charset="UTF-8">

<title itemprop="name">Teen Dies in Memorial Boulevard Collision - LkldNow</title>

<!-- wp_header -->
<title>Teen Dies in Memorial Boulevard Collision - LkldNow</title>

<!-- This site is optimized with the Yoast SEO plugin v13.4.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Teen Dies in Memorial Boulevard Collision - LkldNow" />
<meta property="og:description" content="A 16-year-old car passenger died early Wednesday after the Honda Accord he was in veered into oncoming traffic on East Memorial Boulevard and was hit by a Jeep Compass three lanes away, according to the Lakeland Police Department. Jose Luis Sanchez, 16, was declared dead by first responders following the post-midnight accident near Memorial and &hellip;" />
<meta property="og:url" content="https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/" />
<meta property="og:site_name" content="LkldNow" />
<meta property="article:publisher" content="http://www.facebook.com/lkldnow" />
<meta property="article:tag" content="lkldnow" />
<meta property="article:section" content="Public Safety" />
<meta property="article:published_time" content="2020-04-02T12:55:51+00:00" />
<meta property="article:modified_time" content="2020-04-02T13:40:31+00:00" />
<meta property="og:updated_time" content="2020-04-02T13:40:31+00:00" />
<meta property="og:image" content="https://i0.wp.com/www.lkldnow.com/wp-content/uploads/2019/04/police-lights.jpg?fit=500%2C333&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i0.wp.com/www.lkldnow.com/wp-content/uploads/2019/04/police-lights.jpg?fit=500%2C333&#038;ssl=1" />
<meta property="og:image:width" content="500" />
<meta property="og:image:height" content="333" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="A 16-year-old car passenger died early Wednesday after the Honda Accord he was in veered into oncoming traffic on East Memorial Boulevard and was hit by a Jeep Compass three lanes away, according to the Lakeland Police Department. Jose Luis Sanchez, 16, was declared dead by first responders following the post-midnight accident near Memorial and [&hellip;]" />
<meta name="twitter:title" content="Teen Dies in Memorial Boulevard Collision - LkldNow" />
<meta name="twitter:site" content="@lkldnow" />
<meta name="twitter:image" content="https://www.lkldnow.com/wp-content/uploads/2019/04/police-lights.jpg" />
<meta name="twitter:creator" content="@lkldnow" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.lkldnow.com/#organization","name":"lkldnow","url":"https://www.lkldnow.com/","sameAs":["http://www.facebook.com/lkldnow","http://www.instagram.com/lkldnow","https://www.youtube.com/channel/UCYuuG5aS4799WILZMoIT-PA","https://twitter.com/lkldnow"],"logo":{"@type":"ImageObject","@id":"https://www.lkldnow.com/#logo","inLanguage":"en-US","url":"https://i1.wp.com/www.lkldnow.com/wp-content/uploads/2015/06/white-sticker.jpg?fit=898%2C690&ssl=1","width":898,"height":690,"caption":"lkldnow"},"image":{"@id":"https://www.lkldnow.com/#logo"}},{"@type":"WebSite","@id":"https://www.lkldnow.com/#website","url":"https://www.lkldnow.com/","name":"LkldNow","inLanguage":"en-US","description":"Independent, community-driven news about Lakeland, Fla.","publisher":{"@id":"https://www.lkldnow.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.lkldnow.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/#primaryimage","inLanguage":"en-US","url":"https://i2.wp.com/www.lkldnow.com/wp-content/uploads/2020/04/holly-and-memorial.png?fit=300%2C300&ssl=1","width":300,"height":300},{"@type":"WebPage","@id":"https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/#webpage","url":"https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/","name":"Teen Dies in Memorial Boulevard Collision - LkldNow","isPartOf":{"@id":"https://www.lkldnow.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/#primaryimage"},"datePublished":"2020-04-02T12:55:51+00:00","dateModified":"2020-04-02T13:40:31+00:00","potentialAction":[{"@type":"ReadAction","target":["https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/"]}]},{"@type":"Article","@id":"https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/#article","isPartOf":{"@id":"https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/#webpage"},"author":{"@id":"https://www.lkldnow.com/#/schema/person/5874ef68460e87ef5784e12ffef898ed"},"headline":"Teen Dies in Memorial Boulevard Collision","datePublished":"2020-04-02T12:55:51+00:00","dateModified":"2020-04-02T13:40:31+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/#webpage"},"publisher":{"@id":"https://www.lkldnow.com/#organization"},"image":{"@id":"https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/#primaryimage"},"keywords":"lkldnow","articleSection":"Public Safety","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/#respond"]}]},{"@type":["Person"],"@id":"https://www.lkldnow.com/#/schema/person/5874ef68460e87ef5784e12ffef898ed","name":"Barry Friedman","image":{"@type":"ImageObject","@id":"https://www.lkldnow.com/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/12aa82b3036e8e95e0cb1c399167852f?s=96&d=mm&r=g","caption":"Barry Friedman"},"description":"Lkldnow.com, which I founded in 2015, is the culmination of a career in print and digital journalism. Since 1982, I have used the tools of reporting, editing and content curation to help people in Lakeland and Polk County understand their community better.","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="LkldNow &raquo; Feed" href="https://www.lkldnow.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LkldNow &raquo; Comments Feed" href="https://www.lkldnow.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LkldNow &raquo; Teen Dies in Memorial Boulevard Collision Comments Feed" href="https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.lkldnow.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style>
	.themify_builder .wow { visibility: hidden; }
	div:not(.caroufredsel_wrapper) > .themify_builder_slider > li:not(:first-child), .mfp-hide { display: none; }
a.themify_lightbox, .module-gallery a, .gallery-icon, .themify_lightboxed_images .post a[href$="jpg"], .themify_lightboxed_images .post a[href$="gif"], .themify_lightboxed_images .post a[href$="png"], .themify_lightboxed_images .post a[href$="JPG"], .themify_lightboxed_images .post a[href$="GIF"], .themify_lightboxed_images .post a[href$="PNG"], .themify_lightboxed_images .post a[href$="jpeg"], .themify_lightboxed_images .post a[href$="JPEG"] { cursor:not-allowed; }
	.themify_lightbox_loaded a.themify_lightbox, .themify_lightbox_loaded .module-gallery a, .themify_lightbox_loaded .gallery-icon { cursor:pointer; }
	</style><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='themify-common-css'  href='https://www.lkldnow.com/wp-content/themes/magazine/themify/css/themify.common.min.css?ver=4.8.4' type='text/css' media='all' />
<meta name="themify-framework-css" data-href="https://www.lkldnow.com/wp-content/themes/magazine/themify/css/themify.framework.min.css?ver=4.8.4" content="themify-framework-css" id="themify-framework-css" /><meta name="builder-styles-css" data-href="https://www.lkldnow.com/wp-content/themes/magazine/themify/themify-builder/css/themify-builder-style.min.css?ver=4.8.4" content="builder-styles-css" id="builder-styles-css" />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.4/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='media-credit-css'  href='https://www.lkldnow.com/wp-content/plugins/media-credit/public/css/media-credit.min.css?ver=4.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='mc4wp-form-basic-css'  href='https://www.lkldnow.com/wp-content/plugins/mailchimp-for-wp/assets/css/form-basic.min.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='parent-theme-css-css'  href='https://www.lkldnow.com/wp-content/themes/magazine/style.css?ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='theme-style-css'  href='https://www.lkldnow.com/wp-content/themes/magazine/style.min.css?ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='themify-media-queries-css'  href='https://www.lkldnow.com/wp-content/themes/magazine/media-queries.min.css?ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='theme-style-child-css'  href='https://www.lkldnow.com/wp-content/themes/magazine%20child/style.css?ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='themify-customize-css'  href='https://www.lkldnow.com/wp-content/uploads/themify-customizer.css?ver=20.01.16.09.09.41' type='text/css' media='all' />
<link rel='stylesheet' id='themify-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Oswald|Open+Sans|Open+Sans:300&#038;subset=latin' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.3/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.3/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/related-posts/related-posts.min.js'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5.4'></script>
<link rel='https://api.w.org/' href='https://www.lkldnow.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.lkldnow.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.lkldnow.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4" />
<link rel='shortlink' href='https://wp.me/p74OBK-1IDY' />
<link rel="alternate" type="application/json+oembed" href="https://www.lkldnow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.lkldnow.com%2Fteen-dies-in-memorial-boulevard-collision%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.lkldnow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.lkldnow.com%2Fteen-dies-in-memorial-boulevard-collision%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>

<link href="https://www.lkldnow.com/wp-content/uploads/2015/04/faviconround32.png" rel="shortcut icon" /> 

<!-- Facebook Pixel Code -->
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '155312111724990');
  fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=155312111724990&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->



		<link rel="preconnect" href="https://fonts.googleapis.com" crossorigin/>
	
	<script type="text/javascript">
	    var tf_mobile_menu_trigger_point = 850;
	</script>
	
<meta name="viewport" content="width=device-width, initial-scale=1">
			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="icon" href="https://i0.wp.com/www.lkldnow.com/wp-content/uploads/2015/11/cropped-lkldnowicon512.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/www.lkldnow.com/wp-content/uploads/2015/11/cropped-lkldnowicon512.jpg?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/www.lkldnow.com/wp-content/uploads/2015/11/cropped-lkldnowicon512.jpg?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/www.lkldnow.com/wp-content/uploads/2015/11/cropped-lkldnowicon512.jpg?fit=270%2C270&#038;ssl=1" />
			<style type="text/css" id="wp-custom-css">
				

A judge with art expertise has had a say on her favorite sculptures lining Lemon Street downtown; soon residents will have a chance to vote on their favorites. 

"People's choice" voting will start soon on the city of Lakeland Facebook page, city spokesman Kevin Cook says.

The judge -- Holly Keris, chief curator of the Cummer Museum in Jacksonville -- selected three winners after viewing the 10 downtown sculptures in March.

The winners of the 16th Annual Florida Outdoor Sculpture Competition "all display the perfect bend of artistry, creativity and craftsmanship,” she said.

/*
	CSS Migrated from Jetpack:
*/

			</style>
		<!-- Hotjar Tracking Code for http://www.lkldnow.com/ -->
<script>
    (function(h,o,t,j,a,r){
        h.hj=h.hj||function(){(h.hj.q=h.hj.q||[]).push(arguments)};
        h._hjSettings={hjid:562348,hjsv:5};
        a=o.getElementsByTagName('head')[0];
        r=o.createElement('script');r.async=1;
        r.src=t+h._hjSettings.hjid+j+h._hjSettings.hjsv;
        a.appendChild(r);
    })(window,document,'//static.hotjar.com/c/hotjar-','.js?sv=');
</script>
</head>

<body class="post-template-default single single-post postid-409942 single-format-standard themify-fw-4-8-4 magazine-2-3-2 skin-default webkit not-ie default_width sidebar1 no-home no-touch builder-parallax-scrolling-active">
<script type="text/javascript">
	function themifyMobileMenuTrigger(e) {
		var w = document.body.clientWidth;
		if( w > 0 && w <= tf_mobile_menu_trigger_point ) {
			document.body.classList.add( 'mobile_menu_active' );
		} else {
			document.body.classList.remove( 'mobile_menu_active' );
		}
		
	}
	themifyMobileMenuTrigger();
	var _init =function () {
	    jQuery( window ).on('tfsmartresize.tf_mobile_menu', themifyMobileMenuTrigger );
	    document.removeEventListener( 'DOMContentLoaded', _init, {once:true,passive:true} );
	    _init=null;
	};
	document.addEventListener( 'DOMContentLoaded', _init, {once:true,passive:true} );
</script>
<div id="pagewrap" class="hfeed site">

	<div id="headerwrap">

		<div id="nav-bar">
			<div class="pagewidth clearfix">
									<a id="menu-icon-top" href="#"><i class="fa fa-list-ul icon-list-ul"></i></a>
										<nav id="top-nav-mobile-menu" class="sidemenu sidemenu-off" role="navigation">
						<ul id="top-nav" class="top-nav menu-name-top"><li id="menu-item-2683" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2683"><a href="https://www.lkldnow.com/about/">About</a></li>
<li id="menu-item-2684" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2684"><a href="https://www.lkldnow.com/contact/">Contact</a></li>
<li id="menu-item-52770" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52770"><a href="https://www.lkldnow.com/support_us/">Support Us</a></li>
</ul>					</nav>
									
				<div class="social-widget">
					<div id="themify-social-links-1011" class="widget themify-social-links"><ul class="social-links horizontal">
							<li class="social-link-item facebook font-icon icon-medium">
								<a href="https://www.facebook.com/lkldnow" ><i class="fa fa-facebook" ></i>  </a>
							</li>
							<!-- /themify-link-item -->
							<li class="social-link-item twitter font-icon icon-medium">
								<a href="https://twitter.com/lkldnow" ><i class="fa fa-twitter" ></i>  </a>
							</li>
							<!-- /themify-link-item -->
							<li class="social-link-item instagram font-icon icon-medium">
								<a href="http://instagram.com/lkldnow" ><i class="fa fa-instagram" ></i>  </a>
							</li>
							<!-- /themify-link-item -->
							<li class="social-link-item youtube font-icon icon-medium">
								<a href="https://www.youtube.com/channel/UCYuuG5aS4799WILZMoIT-PA" ><i class="fa fa-youtube" ></i>  </a>
							</li>
							<!-- /themify-link-item -->
							<li class="social-link-item email font-icon icon-medium">
								<a href="mailto:newstips@lkldnow.com" ><i class="fa fa-envelope-o" ></i>  </a>
							</li>
							<!-- /themify-link-item --></ul></div>
											<div class="rss">
							<a href="https://www.lkldnow.com/feed/" class="hs-rss-link">
								<i class="fa fa-icon icon-rss"></i>
							</a>
						</div>
									</div>
				<!-- /.social-widget -->

									<div id="searchform-wrap">
						<div id="search-icon" class="mobile-button"></div>
						<form method="get" id="searchform" action="https://www.lkldnow.com/">
	<i class="fa fa-search icon-search"></i>
	<input type="text" name="s" id="s" placeholder="Search" />

</form>					</div>
					<!-- /#searchform-wrap -->
				
			</div>
		</div>
		<!-- /#nav-bar -->
    
		
		<header id="header" class="pagewidth clearfix">

			<!-- hook content: themify_header_start --><link rel="preload" href="https://www.lkldnow.com/wp-content/themes/magazine/themify/themify-builder/css/themify-builder-style.min.css?ver=4.8.4" as="style" /><script type="text/javascript">
				if(document.getElementById( "themify-builder-style" )===null ){
					var el =  document.getElementById( "builder-styles-css" );
					if(el!==null){
					var link = document.createElement("link");
					link.id="themify-builder-style";
					link.rel="stylesheet";
					link.type="text/css";
					link.href=el.getAttribute("data-href");
					el.parentNode.replaceChild( link, el);
					}
				}
			</script><div class="themify_builder_content themify_builder_content-396344 themify_builder not_editable_builder" data-postid="396344">
    	<!-- module_row -->
	<div  class="themify_builder_row module_row clearfix module_row_0 themify_builder_396344_row module_row_396344-0 tb_noku373">
	    	    <div class="row_inner col_align_top" >
			<div  class="module_column tb-column col-full first tb_396344_column module_column_0 module_column_396344-0-0 tb_ru0w375">
	    	    	        <div class="tb-column-inner">
		        <!-- module image -->
    <div  class="module module-image tb_leob3  image-top donate-image  hide-tablet hide-mobile">
	                <div class="image-wrap">
                            <a href="/support_us/"
                                      >
                                           <img src="https://www.lkldnow.com/wp-content/uploads/2019/05/donate-77x40.png" width="77" height="40" class=" wp-post-image wp-image-396345" alt="donate" srcset="https://i1.wp.com/www.lkldnow.com/wp-content/uploads/2019/05/donate.png?resize=77%2C40&amp;ssl=1 77w, https://i1.wp.com/www.lkldnow.com/wp-content/uploads/2019/05/donate.png?resize=115%2C60&amp;ssl=1 115w, https://i1.wp.com/www.lkldnow.com/wp-content/uploads/2019/05/donate.png?w=192&amp;ssl=1 192w" sizes="(max-width: 77px) 100vw, 77px" />                </a>
            
                        </div>
            <!-- /image-wrap -->
        
        
        </div>
    <!-- /module image -->
	        </div>
	    	</div>
		    </div>
	    <!-- /row_inner -->
	</div>
	<!-- /module_row -->
	</div>
<!-- /hook content: themify_header_start -->
			<div class="hgroup">
				<div id="site-logo"><a href="https://www.lkldnow.com" title="LkldNow"><img src="https://www.lkldnow.com/wp-content/uploads/2019/07/logowtagline24b.png" alt="LkldNow" title="logowtagline24b" /></a></div>			</div>

			<a id="menu-icon" href="#"><i class="fa fa-list-ul icon-list-ul"></i></a>
			<nav id="mobile-menu" class="sidemenu sidemenu-off" role="navigation">
				<ul id="main-nav" class="main-nav menu-name-main"><li id='menu-item-52843' class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home" ><a  href="https://www.lkldnow.com/">Home</a> </li>
<li id='menu-item-2687' class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children has-sub-menu" ><a  href="https://www.lkldnow.com/news/">News</a> 
<ul class="sub-menu">
<li id='menu-item-52988' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="86" data-tax="category"><a  href="https://www.lkldnow.com/category/activism/">Activism</a> </li>
<li id='menu-item-52786' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="31" data-tax="category"><a  href="https://www.lkldnow.com/category/arts/">A &#038; E</a> </li>
<li id='menu-item-52785' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="72" data-tax="category"><a  href="https://www.lkldnow.com/category/business/">Business</a> </li>
<li id='menu-item-52779' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="32" data-tax="category"><a  href="https://www.lkldnow.com/category/city-hall/">City Hall</a> </li>
<li id='menu-item-52782' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="35" data-tax="category"><a  href="https://www.lkldnow.com/category/dining/">Dining</a> </li>
<li id='menu-item-52783' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="38" data-tax="category"><a  href="https://www.lkldnow.com/category/downtown/">Downtown</a> </li>
<li id='menu-item-52781' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="28" data-tax="category"><a  href="https://www.lkldnow.com/category/neighborhoods/">Neighborhoods</a> </li>
<li id='menu-item-52780' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="27" data-tax="category"><a  href="https://www.lkldnow.com/category/people/">People</a> </li>
<li id='menu-item-54930' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="85" data-tax="category"><a  href="https://www.lkldnow.com/category/politics/">Politics</a> </li>
<li id='menu-item-52784' class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent" data-termid="30" data-tax="category"><a  href="https://www.lkldnow.com/category/public-safety/">Public Safety</a> </li>
<li id='menu-item-52984' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="63" data-tax="category"><a  href="https://www.lkldnow.com/category/scenes/">Scenes</a> </li>
<li id='menu-item-53653' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="60" data-tax="category"><a  href="https://www.lkldnow.com/category/schools/">Schools</a> </li>
<li id='menu-item-54232' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://www.lkldnow.com/weather/">Weather</a> </li>
</ul>
</li>
<li id='menu-item-409228' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="245" data-tax="category"><a  href="https://www.lkldnow.com/category/obituaries/">Obituaries</a> </li>
<li id='menu-item-52845' class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children has-sub-menu" ><a  href="https://www.lkldnow.com/lkld-maps/">Info Maps</a> 
<ul class="sub-menu">
<li id='menu-item-318971' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://www.lkldnow.com/weather/">Weather</a> </li>
<li id='menu-item-318974' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://www.lkldnow.com/traffic/">Traffic</a> </li>
<li id='menu-item-318964' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://www.lkldnow.com/i-4-traffic-cameras/">I-4 Cameras</a> </li>
<li id='menu-item-318963' class="menu-item menu-item-type-custom menu-item-object-custom" ><a  href="https://lakelandelectric.com/emergency-information-center">Power Outages</a> </li>
<li id='menu-item-318965' class="menu-item menu-item-type-custom menu-item-object-custom" ><a  href="http://www.raidsonline.com/?address=Lakeland%2CFL">Crime</a> </li>
<li id='menu-item-318966' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://www.lkldnow.com/lkld-maps/">More Maps&#8230;</a> </li>
</ul>
</li>
</ul>				<!-- /#main-nav --> 
			</nav>

			
		</header>
		<!-- /#header -->

        				
	</div>
	<!-- /#headerwrap -->

	<div class="header-widget pagewidth">
			</div>
	<!--/header widget -->

		
	<div id="body" class="clearfix">

    <!-- hook content: themify_layout_before --> <center><broadstreet-zone zone-id="45237" keywords="not_home_page,not_landing_page,is_article_page,public-safety,teen-dies-in-memorial-boulevard-collision,post" soft-keywords="true" zone-alias=""></broadstreet-zone></center><!-- /hook content: themify_layout_before -->

<!-- layout-container -->
<div id="layout" class="pagewidth clearfix">

	<div id="contentwrap">

	
				<!-- content -->
		<div id="content" class="list-post">
			
			


<article itemscope itemtype="http://schema.org/Article" id="post-409942" class="post clearfix cat-30 post-409942 type-post status-publish format-standard has-post-thumbnail hentry category-public-safety tag-lkldnow has-post-title has-post-date has-post-category no-post-tag no-post-comment has-post-author ">
	
		
	
	<div class="post-content">

		                        <p class="post-meta entry-meta">
									<span class="post-category"><a href="https://www.lkldnow.com/category/public-safety/" rel="category tag">Public Safety</a></span>
							</p>
		
												<h1 class="post-title entry-title" itemprop="name"><a href="https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/" title="Teen Dies in Memorial Boulevard Collision">Teen Dies in Memorial Boulevard Collision</a></h1>
						 
		
					<p class="post-meta entry-meta">

															<span class="author-avatar"><img src="https://secure.gravatar.com/avatar/12aa82b3036e8e95e0cb1c399167852f?s=30&#038;d=mm&#038;r=g" width="30" height="30" alt="Avatar" class="avatar avatar-30 wp-user-avatar wp-user-avatar-30 photo avatar-default jetpack-lazy-image" data-lazy-src="https://secure.gravatar.com/avatar/12aa82b3036e8e95e0cb1c399167852f?s=30&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://secure.gravatar.com/avatar/12aa82b3036e8e95e0cb1c399167852f?s=30&#038;d=mm&#038;r=g" width="30" height="30" alt="Avatar" class="avatar avatar-30 wp-user-avatar wp-user-avatar-30 photo avatar-default" /></noscript></span>
						<span class="author-name"><span class="author vcard"><a class="url fn n" href="https://www.lkldnow.com/author/barryf/" rel="author">Barry Friedman</a></span></span>
					
					
									
									 <time datetime="2020-04-02" class="post-date entry-date updated" itemprop="datePublished">Apr 2, 2020 at 8:55 am</time> 	

		</p>	
		
					
<div class="share clearfix">

	
	
	
	
	
	
</div>
<!-- /.share -->		
		
<div class="before-content-widget">

	
</div>
<!-- /before-content-widget -->		
		<div class="entry-content" itemprop="articleBody">

		
			
<div class="wp-block-image"><figure class="alignleft size-large is-resized"><img data-attachment-id="409944" data-permalink="https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/holly-and-memorial/" data-orig-file="https://i2.wp.com/www.lkldnow.com/wp-content/uploads/2020/04/holly-and-memorial.png?fit=300%2C300&amp;ssl=1" data-orig-size="300,300" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="holly-and-memorial" data-image-description="" data-medium-file="https://i2.wp.com/www.lkldnow.com/wp-content/uploads/2020/04/holly-and-memorial.png?fit=300%2C300&amp;ssl=1" data-large-file="https://i2.wp.com/www.lkldnow.com/wp-content/uploads/2020/04/holly-and-memorial.png?fit=300%2C300&amp;ssl=1" src="https://i2.wp.com/www.lkldnow.com/wp-content/uploads/2020/04/holly-and-memorial.png?resize=150%2C150&#038;ssl=1" alt="" class="wp-image-409944" width="150" height="150" srcset="https://i2.wp.com/www.lkldnow.com/wp-content/uploads/2020/04/holly-and-memorial.png?w=300&amp;ssl=1 300w, https://i2.wp.com/www.lkldnow.com/wp-content/uploads/2020/04/holly-and-memorial.png?resize=100%2C100&amp;ssl=1 100w, https://i2.wp.com/www.lkldnow.com/wp-content/uploads/2020/04/holly-and-memorial.png?resize=45%2C45&amp;ssl=1 45w" sizes="(max-width: 150px) 100vw, 150px" data-recalc-dims="1" /><figcaption><span class="media-credit"></span></figcaption></figure></div>



<p>A 16-year-old car passenger died early Wednesday after the Honda Accord he was in veered into oncoming traffic on East Memorial Boulevard and was hit by a Jeep Compass three lanes away, according to the Lakeland Police Department.<span id="more-409942"></span></p>



<p>Jose Luis Sanchez, 16, was declared dead by first responders following the post-midnight accident near Memorial and Holly Road, which is near Sertoma Park overlooking Lake Parker, police said.</p>



<iframe src="https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d3521.102285623501!2d-81.93133294985665!3d28.051901316788204!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x88dd3f67b5835d3d%3A0xf7c59efa8cec06fe!2sHolly%20Rd%20%26%20E%20Memorial%20Blvd%2C%20Lakeland%2C%20FL%2033801!5e0!3m2!1sen!2sus!4v1585831238529!5m2!1sen!2sus" width="600" height="450" frameborder="0" style="border:0;" allowfullscreen="" aria-hidden="false" tabindex="0"></iframe>



<p>Police who responded to the accident at 12:24 a.m. said the Honda driven by Johnathan Joel Acosta, 17, of Lakeland, had been traveling eastward in the inside lane of Memorial and &#8220;for unknown reasons at this time, the Honda veered across the center left-turn lane and into the path of the Jeep Compass,&#8221; which had been traveling west in the outside lane of Memorial.</p>



<p>The Jeep struck the front passenger side of the Honda, police said.</p>



<p>Both drivers were transported to Lakeland Regional Health Medical Center. The driver of the Jeep was identified as Raymond Brian Matt, 42, of Lakeland.</p><aside class="scaip scaip-1    "><aside id="custom_html-2" class="widget_text widget_custom_html clearfix"><div class="textwidget custom-html-widget"><!-- <center><img src="https://i0.wp.com/www.lkldnow.com/wp-content/uploads/2019/07/sponsormessage.png?w=1165&#038;ssl=1" alt="sponsor message" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/www.lkldnow.com/wp-content/uploads/2019/07/sponsormessage.png?w=1165&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i0.wp.com/www.lkldnow.com/wp-content/uploads/2019/07/sponsormessage.png?w=1165&#038;ssl=1" alt="sponsor message" data-recalc-dims="1"></noscript><br><a href="http://wwww.thecityzenship.org"><img src="https://i2.wp.com/www.lkldnow.com/wp-content/uploads/2019/07/cityzenship_300x250.png?resize=300%2C250&#038;ssl=1" alt="cityzenship" width="300" height="250" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/www.lkldnow.com/wp-content/uploads/2019/07/cityzenship_300x250.png?resize=300%2C250&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i2.wp.com/www.lkldnow.com/wp-content/uploads/2019/07/cityzenship_300x250.png?resize=300%2C250&#038;ssl=1" alt="cityzenship" width="300" height="250"  data-recalc-dims="1"></noscript></a></center>
-->
<center><img src="https://i0.wp.com/www.lkldnow.com/wp-content/uploads/2019/07/sponsormessage.png?w=1165&#038;ssl=1" alt="sponsor message" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/www.lkldnow.com/wp-content/uploads/2019/07/sponsormessage.png?w=1165&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i0.wp.com/www.lkldnow.com/wp-content/uploads/2019/07/sponsormessage.png?w=1165&#038;ssl=1" alt="sponsor message" data-recalc-dims="1"></noscript><br><broadstreet-zone zone-id="43907" keywords="not_home_page,not_landing_page,is_article_page,public-safety,teen-dies-in-memorial-boulevard-collision,post" soft-keywords="true" zone-alias=""></broadstreet-zone></center></div></aside></aside>



<p>Memorial Boulevard was shout down until around 6 a.m. Wednesday as the scene was processed.</p>



<p>Police ask anyone with information about the accident to contact contact Traffic Homicide Investigator Tyler Anderson at 863.834.2553 or <a href="mailto:tyler.anderson@lakelandgov.net">tyler.anderson@lakelandgov.net</a>. </p>



<div class="wp-block-group"><div class="wp-block-group__inner-container">
	<!-- shortcode box --> <div class="shortcode clearfix box   rounded shadow"><a href="https://i1.wp.com/www.lkldnow.com/wp-content/uploads/2016/10/lkldskylinesq.jpg?ssl=1"><img class="size-thumbnail wp-image-347265 alignleft" src="https://i1.wp.com/www.lkldnow.com/wp-content/uploads/2016/10/lkldskylinesq.jpg?resize=100%2C100&ssl=1" sizes="(max-width: 100px) 100vw, 100px" srcset="https://i1.wp.com/www.lkldnow.com/wp-content/uploads/2016/10/lkldskylinesq.jpg?resize=100%2C100&ssl=1 100w, https://i1.wp.com/www.lkldnow.com/wp-content/uploads/2016/10/lkldskylinesq.jpg?w=264&ssl=1 264w" alt="Lakeland skyline" width="100" height="100" data-recalc-dims="1" /></a><span style="font-size: 14pt;"><strong>Support Independent Community News.</strong>
</span>We rely on people like you to invest in the community by <a href="https://www.lkldnow.com/support_us/">supporting this non-profit service</a>.
<a href="https://www.lkldnow.com/support_us/" class="shortcode button    large" style="background-color: #0087c0;color: #fff;">Donate</a></div> <!-- /shortcode box -->


<nav class="jp-relatedposts-i2" data-layout="grid"><div class="jp-related-posts-i2__row" data-post-count="3"><ul id="related-posts-item-5e85fc5b7acf1" aria-labelledby="related-posts-item-5e85fc5b7acf1-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-5e85fc5b7acf1-label" href="https://www.lkldnow.com/avoid-4-near-kathleen-road-alternative-us-92/" >Four Die in 7-Vehicle Crash on I-4 Near Memorial Boulevard</a></li><li class="jp-related-posts-i2__post-date">June 21, 2016</li></ul><ul id="related-posts-item-5e85fc5b7ad15" aria-labelledby="related-posts-item-5e85fc5b7ad15-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-5e85fc5b7ad15-label" href="https://www.lkldnow.com/pedestrian/" >Pedestrian Walking Between Lanes Struck, Killed</a></li><li class="jp-related-posts-i2__post-date">June 6, 2017</li></ul><ul id="related-posts-item-5e85fc5b7ad28" aria-labelledby="related-posts-item-5e85fc5b7ad28-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-5e85fc5b7ad28-label" href="https://www.lkldnow.com/pedestrian-fatality-harden-blvd-causing-backups/" >Pedestrian With Walker, 53, Dies on Harden Boulevard</a></li><li class="jp-related-posts-i2__post-date">August 23, 2017</li></ul></div></nav></div></div>


<div id="themify_builder_content-409942" data-postid="409942" class="themify_builder_content themify_builder_content-409942 themify_builder tb_generate_css" style="visibility:hidden;opacity:0;">
    </div>

<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-409942" class="share-facebook sd-button share-icon no-text" href="https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-409942" class="share-twitter sd-button share-icon no-text" href="https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-409942" class="share-pinterest sd-button share-icon no-text" href="https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-409942" class="share-linkedin sd-button share-icon no-text" href="https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>		
		
		</div><!-- /.entry-content -->
		
				
	</div>
	<!-- /.post-content -->
		
</article>
<!-- /.post -->


			
			
			
<div class="after-content-widget">

	
</div>
<!-- /after-content-widget -->			
			
			
							


<div id="comments" class="commentwrap">

	
	
	
		
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Your Thoughts On This? (When you sign in, please use your full name.)					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/teen-dies-in-memorial-boulevard-collision/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=104582204&#038;postid=409942&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=0&#038;stb_enabled=0&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Your+Thoughts+On+This%3F+%28When+you+sign+in%2C+please+use+your+full+name.%29&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.3&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=21f9942a4ffbc21e039bec80eaf37849558b1785#parent=https%3A%2F%2Fwww.lkldnow.com%2Fteen-dies-in-memorial-boulevard-collision%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
	
	
</div>
<!-- /.commentwrap -->


			
					</div>
		<!-- /content -->
		
	
	</div>
	<!-- /#contentwrap -->

	    
    <aside id="sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSidebar">

            
            <div id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="47694" keywords="not_home_page,not_landing_page,is_article_page,public-safety,teen-dies-in-memorial-boulevard-collision,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="custom_html-4" class="widget_text widget widget_custom_html"><h4 class="widgettitle">Coronavirus</h4><div class="textwidget custom-html-widget"><img src="https://i1.wp.com/www.lkldnow.com/wp-content/uploads/2020/03/local-resources.jpg?resize=300%2C79&#038;ssl=1" width="300" height="79" alt="local resources" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/www.lkldnow.com/wp-content/uploads/2020/03/local-resources.jpg?resize=300%2C79&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i1.wp.com/www.lkldnow.com/wp-content/uploads/2020/03/local-resources.jpg?resize=300%2C79&#038;ssl=1" width="300" height="79" alt="local resources" data-recalc-dims="1"></noscript><br>
<ul>
<li>
<a href="https://fdoh.maps.arcgis.com/apps/opsdashboard/index.html?fbclid=IwAR2g09TKHW5JHmXsgQ5XQIyHzJpl5ZHNhie0UJj477ZlkZbSKZ3sK4Oe_eE#/8d0de33f260d444c852a615dc7837c86">Florida interactive map</a>
</li>
<li>
<a href="https://floridahealthcovid19.gov/#latest-stats/">Florida current situation</a>
</li>
<li>
<a href="https://www.lkldnow.com/tag/coronavirus/">LkldNow coverage</a>
</li>
<li><a href="http://www.lakelandgov.net/departments/lakeland-fire-department/emergency-management/coronavirus-covid-19/">City of Lakeland updates</a>
</li>
<li>
<a href="https://polkschoolsfl.com/lunchlocations/">School lunches</a>
</li>
<li>
<a href="https://lakelandmom.com/grocery-shopping-hours-locations/">Grocery store hours</a>
</li>
<li>
<a href="https://docs.google.com/document/d/e/2PACX-1vTbvI2gmUuIF5wH6wZ9VwwBdsf6kICBc30dUit_sWEkKve-5JIzBka38uXG4KRyQfaEgCZqjO7I1i6N/pub?fbclid=IwAR36vNLPc2YfhOHyUzQ-qgaS5EAelT0viCsusKMj1rnX8zKEbG9DerRqsEQ/">Restaurant updates via Lakeland Food Group on Facebook</a>
</li>
<li><a href="http://blog.lakelandchamber.com/2020/03/chamber-restaurants-takeout-delivery-options/">Restaurant options via Lakeland Chamber</a>
</li>
<li>
<a href="https://uwcf.org/initiatives/endhunger/schedule#toggle-id-6">Food pantries</a>
</li>
<li>
<a href="https://www.lakelandchamber.com/programs-events/gift-card-incentive/">Buy gift cards to support local businesses</a>
</li>
</ul>
</div></div><style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 700;
font-size: 14px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><div id="rpwe_widget-3" class="widget rpwe_widget recent-posts-extended"><h4 class="widgettitle">LKLDNOW ORIGINALS</h4><div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.lkldnow.com/covid-19-in-polk-wednesday-evening/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.lkldnow.com/wp-content/uploads/2020/04/wednesday91-45x45.png" alt="COVID-19 in Polk: Wednesday Evening"></a><h3 class="rpwe-title"><a href="https://www.lkldnow.com/covid-19-in-polk-wednesday-evening/" title="Permalink to COVID-19 in Polk: Wednesday Evening" rel="bookmark">COVID-19 in Polk: Wednesday Evening</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.lkldnow.com/all-city-parks-and-trails-will-close-friday-morning/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.lkldnow.com/wp-content/uploads/2020/04/beerman-park-closed-sq-45x45.png" alt="All City Parks and Trails Will Close Friday Morning"></a><h3 class="rpwe-title"><a href="https://www.lkldnow.com/all-city-parks-and-trails-will-close-friday-morning/" title="Permalink to All City Parks and Trails Will Close Friday Morning" rel="bookmark">All City Parks and Trails Will Close Friday Morning</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.lkldnow.com/citrus-connection-will-reduce-bus-service-starting-monday/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.lkldnow.com/wp-content/uploads/2020/04/citrus-connection-bus-sq-45x45.png" alt="Citrus Connection Will Reduce Bus Service Starting Monday"></a><h3 class="rpwe-title"><a href="https://www.lkldnow.com/citrus-connection-will-reduce-bus-service-starting-monday/" title="Permalink to Citrus Connection Will Reduce Bus Service Starting Monday" rel="bookmark">Citrus Connection Will Reduce Bus Service Starting Monday</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.lkldnow.com/city-commission-meeting-on-parks-policing-at-3-today/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.lkldnow.com/wp-content/uploads/2020/04/city-hall-sq-45x45.png" alt="City Commission Meeting on Parks, Policing at 3 Today"></a><h3 class="rpwe-title"><a href="https://www.lkldnow.com/city-commission-meeting-on-parks-policing-at-3-today/" title="Permalink to City Commission Meeting on Parks, Policing at 3 Today" rel="bookmark">City Commission Meeting on Parks, Policing at 3 Today</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.lkldnow.com/covid-19-in-polk-tuesday-evening/"  rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.lkldnow.com/wp-content/uploads/2020/04/polk-chart-march-31-sq-45x45.png" alt="COVID-19 in Polk: Tuesday Evening"></a><h3 class="rpwe-title"><a href="https://www.lkldnow.com/covid-19-in-polk-tuesday-evening/" title="Permalink to COVID-19 in Polk: Tuesday Evening" rel="bookmark">COVID-19 in Polk: Tuesday Evening</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --><a href="/tag/lkldnow/">More 
 &gt;</a></div>		<div id="recent-posts-4" class="widget widget_recent_entries">		<h4 class="widgettitle">Recent Posts</h4>		<ul>
											<li>
					<a href="https://www.lkldnow.com/teen-dies-in-memorial-boulevard-collision/" aria-current="page">Teen Dies in Memorial Boulevard Collision</a>
									</li>
											<li>
					<a href="https://www.lkldnow.com/covid-19-in-polk-wednesday-evening/">COVID-19 in Polk: Wednesday Evening</a>
									</li>
											<li>
					<a href="https://www.lkldnow.com/watson-clinic-doctor-explain-whos-getting-covid-19-tests/"><a href="https://www.baynews9.com/fl/tampa/news/2020/04/02/watson-urgent-care-seeing-steady-influx-of-patients-with-covid-19-symptoms">Watson Clinic Doctor Explain Who&#8217;s Getting COVID-19 Tests</a></a>
									</li>
											<li>
					<a href="https://www.lkldnow.com/all-city-parks-and-trails-will-close-friday-morning/">All City Parks and Trails Will Close Friday Morning</a>
									</li>
											<li>
					<a href="https://www.lkldnow.com/gov-desantis-issues-stay-at-home-order-effective-thursday/"><a href="https://www.tampabay.com/news/health/2020/04/01/florida-gov-ron-desantis-issues-statewide-stay-at-home-order/" >Gov. DeSantis Issues Stay-at-Home Order Effective Thursday</a></a>
									</li>
					</ul>
		</div><div id="text-1005" class="widget widget_text"><h4 class="widgettitle">Highlights email</h4>			<div class="textwidget"><p>Weekly newsletter coming soon.<br />
<script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><!-- Mailchimp for WordPress v4.7.5 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-372080 mc4wp-form-basic" method="post" data-id="372080" data-name="Default sign-up form" ><div class="mc4wp-form-fields"><p>
	Get occasional updates on LkldNow and what we're up to. Sign up:</p>
<p> 
	<input type="email" id="mc4wp_email" name="EMAIL" placeholder="Your email address" required />
</p>

<p>
	<input type="submit" value="Sign up" />
</p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1585839195" /><input type="hidden" name="_mc4wp_form_id" value="372080" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin --></p>
</div>
		</div>
            <div class="clearfix">

                    <div class="secondary">
                                                </div>

                    <div class="secondary last">
                                                </div>

            </div>

            
            
    </aside>
    <!-- /#sidebar -->

    
</div>
<!-- /layout-container -->
	

	    </div>
	<!-- /body -->
		
	<div id="footerwrap">
    
    			<footer id="footer" class="pagewidth clearfix">
			
			<p class="back-top">
				<a href="#header">Back to Top</a>
			</p>

			
	<div class="footer-widgets clearfix">

								<div class="col3-1 first">
				<div id="mc4wp_form_widget-6" class="widget widget_mc4wp_form_widget"><h4 class="widgettitle">Newsletter</h4><script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><!-- Mailchimp for WordPress v4.7.5 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-2" class="mc4wp-form mc4wp-form-372080 mc4wp-form-basic" method="post" data-id="372080" data-name="Default sign-up form" ><div class="mc4wp-form-fields"><p>
	Get occasional updates on LkldNow and what we're up to. Sign up:</p>
<p> 
	<input type="email" id="mc4wp_email" name="EMAIL" placeholder="Your email address" required />
</p>

<p>
	<input type="submit" value="Sign up" />
</p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1585839195" /><input type="hidden" name="_mc4wp_form_id" value="372080" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-2" /><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin --></div>			</div>
								<div class="col3-1 ">
				<div id="text-1007" class="widget widget_text"><h4 class="widgettitle">Contact us</h4>			<div class="textwidget"><p>Send tips, feedback, corrections to <a href="mailto:newstips@lkldnow.com">newstips@lkldnow.com</a></p>
</div>
		</div>			</div>
								<div class="col3-1 ">
							</div>
		
	</div>
	<!-- /.footer-widgets -->


			<div class="social-widget">
				<div id="themify-social-links-1014" class="widget themify-social-links"><ul class="social-links horizontal">
							<li class="social-link-item facebook font-icon icon-large">
								<a href="https://www.facebook.com/lkldnow" ><i class="fa fa-facebook" ></i>  </a>
							</li>
							<!-- /themify-link-item -->
							<li class="social-link-item twitter font-icon icon-large">
								<a href="https://twitter.com/lkldnow" ><i class="fa fa-twitter" ></i>  </a>
							</li>
							<!-- /themify-link-item -->
							<li class="social-link-item instagram font-icon icon-large">
								<a href="http://instagram.com/lkldnow" ><i class="fa fa-instagram" ></i>  </a>
							</li>
							<!-- /themify-link-item -->
							<li class="social-link-item youtube font-icon icon-large">
								<a href="https://www.youtube.com/channel/UCYuuG5aS4799WILZMoIT-PA" ><i class="fa fa-youtube" ></i>  </a>
							</li>
							<!-- /themify-link-item -->
							<li class="social-link-item email font-icon icon-large">
								<a href="mailto:newstips@lkldnow.com" ><i class="fa fa-envelope-o" ></i>  </a>
							</li>
							<!-- /themify-link-item --></ul></div>			</div>
			<!-- /.social-widget -->

			<div class="footer-nav-wrap">
							</div>
	
			<div class="footer-text clearfix">
				 <div class="one"><a href="/terms-of-service/">Terms of Service</a> | <a href="/privacy-policy/">Privacy Policy</a> <br>Lakeland, Florida</div>				 Copyright &copy; 2020 lkldnow.com
			</div>
			<!-- /footer-text --> 
			<!-- hook content: themify_footer_end --><script type="text/javascript">
//<![CDATA[
jQuery(document).ready(function($) {
$('a').each(function() {
var a = new RegExp('/' + window.location.host + '/');
if(!a.test(this.href)) {
$(this).click(function(event) {
event.preventDefault();
event.stopPropagation();
window.open(this.href, '_blank');
});
}
});
});
//]]>
</script><!-- /hook content: themify_footer_end -->
		</footer>
		<!-- /#footer --> 
        <!-- hook content: themify_footer_after --><script>
function init() {
var vidDefer = document.getElementsByTagName('iframe');
for (var i=0; i<vidDefer.length; i++) {
if(vidDefer[i].getAttribute('data-src')) {
vidDefer[i].setAttribute('src',vidDefer[i].getAttribute('data-src'));
} } }
window.onload = init;
</script><!-- /hook content: themify_footer_after -->	</div>
	<!-- /#footerwrap -->
	
</div>
<!-- /#pagewrap -->


<!-- SCHEMA BEGIN --><script type="application/ld+json">[{"@context":"https:\/\/schema.org","@type":"BlogPosting","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.lkldnow.com\/teen-dies-in-memorial-boulevard-collision\/"},"headline":"Teen Dies in Memorial Boulevard Collision","datePublished":"2020-04-02T08:55:51-04:00","dateModified":"2020-04-02T08:55:51-04:00","author":{"@type":"Person","name":"Barry Friedman"},"publisher":{"@type":"Organization","name":"","logo":{"@type":"ImageObject","url":"","width":0,"height":0}},"description":"A 16-year-old car passenger died early Wednesday after the Honda Accord he was in veered into oncoming traffic on East Memorial Boulevard and was hit by a Jeep Compass three lanes away, according to the Lakeland Police Department. Jose Luis Sanchez, 16, was declared dead by first responders following the post-midnight accident near Memorial and [&hellip;]","image":{"@type":"ImageObject","url":"https:\/\/i2.wp.com\/www.lkldnow.com\/wp-content\/uploads\/2020\/04\/holly-and-memorial.png?fit=300%2C300&ssl=1","width":300,"height":300}}]</script><!-- /SCHEMA END --><!-- wp_footer -->


<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','public-safety','teen-dies-in-memorial-boulevard-collision','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["public-safety","teen-dies-in-memorial-boulevard-collision","post"],"url":"teen-dies-in-memorial-boulevard-collision"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.watch({});
 });</script><!-- Universal Google Analytics -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-64056342-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- End Universal Google Analytics -->
<script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.lkldnow.com\/teen-dies-in-memorial-boulevard-collision\/":409942};
	</script>
							<div id="sharing_email" style="display: none;">
		<form action="/teen-dies-in-memorial-boulevard-collision/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://www.lkldnow.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript'>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</script>
<script type='text/javascript' defer="defer" src='https://www.lkldnow.com/wp-content/themes/magazine/themify/js/main.min.js?ver=4.8.4'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' defer="defer" src='https://www.lkldnow.com/wp-content/themes/magazine/js/jquery.scroll.min.js?ver=5.4'></script>
<script type='text/javascript' defer="defer" src='https://www.lkldnow.com/wp-content/themes/magazine/js/themify.sidemenu.min.js?ver=5.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var themifyScript = {"themeURI":"https:\/\/www.lkldnow.com\/wp-content\/themes\/magazine","lightbox":{"lightboxSelector":".themify_lightbox","lightboxOn":true,"lightboxContentImages":false,"lightboxContentImagesSelector":"","theme":"pp_default","social_tools":false,"allow_resize":true,"show_title":false,"overlay_gallery":false,"screenWidthNoLightbox":600,"deeplinking":false,"contentImagesAreas":"","gallerySelector":".gallery-icon > a","lightboxGalleryOn":true},"fixedHeader":"fixed-header","ajax_nonce":"acf49b509c","ajax_url":"https:\/\/www.lkldnow.com\/wp-admin\/admin-ajax.php","events":"mouseenter","top_nav_side":"left","main_nav_side":"right"};
/* ]]> */
</script>
<script type='text/javascript' defer="defer" src='https://www.lkldnow.com/wp-content/themes/magazine/js/themify.script.min.js?ver=5.4'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/spin.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/jquery.spin.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.lkldnow.com\/wp-admin\/admin-ajax.php","nonce":"7eb2f34ce1","display_exif":"0","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.lkldnow.com\/wp-login.php?redirect_to=https%3A%2F%2Fwww.lkldnow.com%2Fteen-dies-in-memorial-boulevard-collision%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/carousel/jetpack-carousel.min.js'></script>
<script async="async" type='text/javascript' src='https://www.lkldnow.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.4'></script>
<script type='text/javascript' src='https://www.lkldnow.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms.min.js?ver=4.7.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=104582204&postid=409942&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=mystery&greeting=Your+Thoughts+On+This%3F+%28When+you+sign+in%2C+please+use+your+full+name.%29&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=21f9942a4ffbc21e039bec80eaf37849558b1785#parent=https%3A%2F%2Fwww.lkldnow.com%2Fteen-dies-in-memorial-boulevard-collision%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=104582204&postid=409942&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=mystery&greeting=Your+Thoughts+On+This%3F+%28When+you+sign+in%2C+please+use+your+full+name.%29&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=21f9942a4ffbc21e039bec80eaf37849558b1785#parent=https%3A%2F%2Fwww.lkldnow.com%2Fteen-dies-in-memorial-boulevard-collision%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202014.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'104582204',post:'409942',tz:'-4',srv:'www.lkldnow.com'} ]);
	_stq.push([ 'clickTrackerInit', '104582204', '409942' ]);
</script>

</body>
</html>