<!doctype html>
<html  lang="en-US" prefix="og: https://ogp.me/ns#">
<head>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=G-2W01Y9096R"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'G-2W01Y9096R');
</script>
	
<meta charset="UTF-8">

<title itemprop="name">Republican Field for Congressional District 15 Getting More Crowded - LkldNow</title>

<!-- wp_header -->

<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
</script>
<!-- End Google Tag Manager for WordPress by gtm4wp.com -->
<!-- Search Engine Optimization by Rank Math PRO - https://s.rankmath.com/home -->
<title>Republican Field for Congressional District 15 Getting More Crowded - LkldNow</title>
<meta name="Googlebot-News" content="noindex" />
<meta name="robots" content="follow, noindex"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Republican Field for Congressional District 15 Getting More Crowded - LkldNow" />
<meta property="og:description" content="Another Republican has joined the primary race to represent a U.S. House district that includes the western half of Lakeland. Previously, the District 15 primary battle had been between former U.S. Rep. Dennis Ross of Lakeland, former Florida Rep. Jackie Toledo of Tampa, and retired Navy Cmd. Demetries Grimes of Poinciana. Now Jay Collins of [&hellip;]" />
<meta property="og:url" content="https://www.lkldnow.com/republican-field-for-congressional-district-15-getting-more-crowded/" />
<meta property="og:site_name" content="LkldNow" />
<meta property="article:publisher" content="http://www.facebook.com/lkldnow" />
<meta property="article:tag" content="curated" />
<meta property="article:section" content="Politics" />
<meta property="og:updated_time" content="2022-05-03T15:00:36-04:00" />
<meta property="article:published_time" content="2022-05-03T15:00:30-04:00" />
<meta property="article:modified_time" content="2022-05-03T15:00:36-04:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Republican Field for Congressional District 15 Getting More Crowded - LkldNow" />
<meta name="twitter:description" content="Another Republican has joined the primary race to represent a U.S. House district that includes the western half of Lakeland. Previously, the District 15 primary battle had been between former U.S. Rep. Dennis Ross of Lakeland, former Florida Rep. Jackie Toledo of Tampa, and retired Navy Cmd. Demetries Grimes of Poinciana. Now Jay Collins of [&hellip;]" />
<meta name="twitter:site" content="@lkldnow" />
<meta name="twitter:creator" content="@lkldnow" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Barry Friedman" />
<meta name="twitter:label2" content="Time to read" />
<meta name="twitter:data2" content="Less than a minute" />
<script type="application/ld+json" class="rank-math-schema-pro">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.lkldnow.com/#organization","name":"lkldnow","url":"https://www.lkldnow.com","logo":{"@type":"ImageObject","@id":"https://www.lkldnow.com/#logo","url":"https://www.lkldnow.com/wp-content/uploads/2015/06/white-sticker.jpg","caption":"lkldnow","inLanguage":"en-US","width":"898","height":"690"}},{"@type":"WebSite","@id":"https://www.lkldnow.com/#website","url":"https://www.lkldnow.com","name":"lkldnow","publisher":{"@id":"https://www.lkldnow.com/#organization"},"inLanguage":"en-US"},{"@type":"Person","@id":"https://www.lkldnow.com/author/barryf/","name":"Barry Friedman","url":"https://www.lkldnow.com/author/barryf/","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/12aa82b3036e8e95e0cb1c399167852f?s=96&amp;d=mm&amp;r=g","url":"https://secure.gravatar.com/avatar/12aa82b3036e8e95e0cb1c399167852f?s=96&amp;d=mm&amp;r=g","caption":"Barry Friedman","inLanguage":"en-US"},"worksFor":{"@id":"https://www.lkldnow.com/#organization"}},{"@type":"WebPage","@id":"https://www.lkldnow.com/republican-field-for-congressional-district-15-getting-more-crowded/#webpage","url":"https://www.lkldnow.com/republican-field-for-congressional-district-15-getting-more-crowded/","name":"Republican Field for Congressional District 15 Getting More Crowded - LkldNow","datePublished":"2022-05-03T15:00:30-04:00","dateModified":"2022-05-03T15:00:36-04:00","author":{"@id":"https://www.lkldnow.com/author/barryf/"},"isPartOf":{"@id":"https://www.lkldnow.com/#website"},"inLanguage":"en-US"},{"@type":"NewsArticle","headline":"Republican Field for Congressional District 15 Getting More Crowded - LkldNow","datePublished":"2022-05-03T15:00:30-04:00","dateModified":"2022-05-03T15:00:36-04:00","author":{"@id":"https://www.lkldnow.com/author/barryf/"},"publisher":{"@id":"https://www.lkldnow.com/#organization"},"description":"Another Republican has joined the primary race to represent a U.S. House district that includes the western half of Lakeland. Previously, the District 15 primary battle had been between former U.S. Rep. Dennis Ross of Lakeland, former Florida Rep. Jackie Toledo of Tampa, and retired Navy Cmd. Demetries Grimes of Poinciana. Now Jay Collins of Tampa has entered the race, the Tampa Bay Times reports. He had been considered the front-runner in the GOP primary to oppose Democratic District 14 incumbent Kathy Castor, but reapportionment left that district more Democrat-leaning and opened a vacancy in a Republican-leaning, redrawn 15th District.","copyrightYear":"2022","copyrightHolder":{"@id":"https://www.lkldnow.com/#organization"},"name":"Republican Field for Congressional District 15 Getting More Crowded - LkldNow","@id":"https://www.lkldnow.com/republican-field-for-congressional-district-15-getting-more-crowded/#richSnippet","isPartOf":{"@id":"https://www.lkldnow.com/republican-field-for-congressional-district-15-getting-more-crowded/#webpage"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.lkldnow.com/republican-field-for-congressional-district-15-getting-more-crowded/#webpage"}}]}</script>
<!-- /Rank Math WordPress SEO plugin -->

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="LkldNow &raquo; Feed" href="https://www.lkldnow.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LkldNow &raquo; Comments Feed" href="https://www.lkldnow.com/comments/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.lkldnow.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style>
	.themify_builder .wow { visibility: hidden; }
	div:not(.caroufredsel_wrapper) > .themify_builder_slider > li:not(:first-child), .mfp-hide { display: none; }
a.themify_lightbox, .module-gallery a, .gallery-icon, .themify_lightboxed_images .post a[href$="jpg"], .themify_lightboxed_images .post a[href$="gif"], .themify_lightboxed_images .post a[href$="png"], .themify_lightboxed_images .post a[href$="JPG"], .themify_lightboxed_images .post a[href$="GIF"], .themify_lightboxed_images .post a[href$="PNG"], .themify_lightboxed_images .post a[href$="jpeg"], .themify_lightboxed_images .post a[href$="JPEG"] { cursor:not-allowed; }
	.themify_lightbox_loaded a.themify_lightbox, .themify_lightbox_loaded .module-gallery a, .themify_lightbox_loaded .gallery-icon { cursor:pointer; }
	</style><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<!-- `jetpack_related-posts` is included in the concatenated jetpack.css -->
<link rel='stylesheet' id='themify-common-css'  href='https://www.lkldnow.com/wp-content/themes/magazine/themify/css/themify.common.min.css?ver=4.9.2' type='text/css' media='all' />
<meta name="themify-framework-css" data-href="https://www.lkldnow.com/wp-content/themes/magazine/themify/css/themify.framework.min.css?ver=4.9.2" content="themify-framework-css" id="themify-framework-css" /><meta name="builder-styles-css" data-href="https://www.lkldnow.com/wp-content/themes/magazine/themify/themify-builder/css/themify-builder-style.min.css?ver=4.9.2" content="builder-styles-css" id="builder-styles-css" />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.lkldnow.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.3' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://www.lkldnow.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://www.lkldnow.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.9.3' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='media-credit-css'  href='https://www.lkldnow.com/wp-content/plugins/media-credit/public/css/media-credit.min.css?ver=4.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='parent-theme-css-css'  href='https://www.lkldnow.com/wp-content/themes/magazine/style.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='theme-style-css'  href='https://www.lkldnow.com/wp-content/themes/magazine/style.min.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='themify-media-queries-css'  href='https://www.lkldnow.com/wp-content/themes/magazine/media-queries.min.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='theme-style-child-css'  href='https://www.lkldnow.com/wp-content/themes/magazine%20child/style.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='themify-customize-css'  href='https://www.lkldnow.com/wp-content/uploads/themify-customizer.css?ver=22.04.25.16.42.37' type='text/css' media='all' />
<link rel='stylesheet' id='themify-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Oswald%7COpen+Sans%7COpen+Sans:300&#038;subset=latin' type='text/css' media='all' />
<!-- `sharedaddy` is included in the concatenated jetpack.css -->
<link rel='stylesheet' id='social-logos-css'  href='https://www.lkldnow.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=10.8' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.lkldnow.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.8' type='text/css' media='all' />
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.lkldnow.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20211209' id='jetpack_related-posts-js'></script>
<script type='text/javascript' src='https://www.lkldnow.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.lkldnow.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?v=1.43.8&#038;ver=5.9.3' id='broadstreet-cdn-js'></script>
<link rel="https://api.w.org/" href="https://www.lkldnow.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.lkldnow.com/wp-json/wp/v2/posts/456458" /><link rel='shortlink' href='https://wp.me/p74OBK-1UKe' />
<link rel="alternate" type="application/json+oembed" href="https://www.lkldnow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.lkldnow.com%2Frepublican-field-for-congressional-district-15-getting-more-crowded%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.lkldnow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.lkldnow.com%2Frepublican-field-for-congressional-district-15-getting-more-crowded%2F&#038;format=xml" />

<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<!-- GTM Container placement set to footer -->
<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">
	const console_cmd = console.warn || console.log;
	var dataLayer_content = {"pagePostType":"post","pagePostType2":"single-post","pageCategory":["politics"],"pageAttributes":["curated"],"pagePostAuthor":"Barry Friedman"};
	dataLayer.push( dataLayer_content );
</script>
<script data-cfasync="false">
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MHLDLMK');
</script>
<!-- End Google Tag Manager -->
<!-- End Google Tag Manager for WordPress by gtm4wp.com --><style type='text/css'>img#wpstats{display:none}</style>
	

<link href="https://www.lkldnow.com/wp-content/uploads/2015/04/faviconround32.png" rel="shortcut icon" /> 




		<link rel="preconnect" href="https://fonts.googleapis.com" crossorigin/>
	
	<script type="text/javascript">
	    var tf_mobile_menu_trigger_point = 850;
	</script>
	
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="icon" href="https://www.lkldnow.com/wp-content/uploads/2015/11/cropped-lkldnowicon512-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://www.lkldnow.com/wp-content/uploads/2015/11/cropped-lkldnowicon512-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.lkldnow.com/wp-content/uploads/2015/11/cropped-lkldnowicon512-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://www.lkldnow.com/wp-content/uploads/2015/11/cropped-lkldnowicon512-270x270.jpg" />
		<style type="text/css" id="wp-custom-css">
			

A judge with art expertise has had a say on her favorite sculptures lining Lemon Street downtown; soon residents will have a chance to vote on their favorites. 

"People's choice" voting will start soon on the city of Lakeland Facebook page, city spokesman Kevin Cook says.

The judge -- Holly Keris, chief curator of the Cummer Museum in Jacksonville -- selected three winners after viewing the 10 downtown sculptures in March.

The winners of the 16th Annual Florida Outdoor Sculpture Competition "all display the perfect bend of artistry, creativity and craftsmanship,” she said.

/*
	CSS Migrated from Jetpack:
*/

		</style>
		<!-- Facebook Pixel Code -->
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '155312111724990');
  fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=155312111724990&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->
<!-- Hotjar Tracking Code for http://www.lkldnow.com/ -->
<script>
    (function(h,o,t,j,a,r){
        h.hj=h.hj||function(){(h.hj.q=h.hj.q||[]).push(arguments)};
        h._hjSettings={hjid:562348,hjsv:5};
        a=o.getElementsByTagName('head')[0];
        r=o.createElement('script');r.async=1;
        r.src=t+h._hjSettings.hjid+j+h._hjSettings.hjsv;
        a.appendChild(r);
    })(window,document,'//static.hotjar.com/c/hotjar-','.js?sv=');
</script>
</head>

<body class="post-template-default single single-post postid-456458 single-format-standard themify-fw-4-9-2 magazine-2-4-1 skin-default webkit not-ie default_width sidebar1 no-home no-touch builder-parallax-scrolling-active">
<script type="text/javascript">
	function themifyMobileMenuTrigger(e) {
		var w = document.body.clientWidth;
		if( w > 0 && w <= tf_mobile_menu_trigger_point ) {
			document.body.classList.add( 'mobile_menu_active' );
		} else {
			document.body.classList.remove( 'mobile_menu_active' );
		}
		
	}
	themifyMobileMenuTrigger();
	var _init =function () {
	    jQuery( window ).on('tfsmartresize.tf_mobile_menu', themifyMobileMenuTrigger );
	    document.removeEventListener( 'DOMContentLoaded', _init, {once:true,passive:true} );
	    _init=null;
	};
	document.addEventListener( 'DOMContentLoaded', _init, {once:true,passive:true} );
</script>
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div id="pagewrap" class="hfeed site">

	<div id="headerwrap">

		<div id="nav-bar">
			<div class="pagewidth clearfix">
									<a id="menu-icon-top" href="#"><i class="fa fa-list-ul icon-list-ul"></i></a>
										<nav id="top-nav-mobile-menu" class="sidemenu sidemenu-off" role="navigation">
						<ul id="top-nav" class="top-nav menu-name-top"><li id="menu-item-52770" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52770"><a href="https://www.lkldnow.com/support_us/">Support Us</a></li>
<li id="menu-item-2683" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2683"><a href="https://www.lkldnow.com/about/">About</a></li>
<li id="menu-item-2684" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2684"><a href="https://www.lkldnow.com/contact/">Contact</a></li>
</ul>					</nav>
									
				<div class="social-widget">
					<div id="themify-social-links-1011" class="widget themify-social-links"><ul class="social-links horizontal">
							<li class="social-link-item facebook font-icon icon-medium">
								<a href="https://www.facebook.com/lkldnow" aria-label="facebook" ><i class="fa fa-facebook" ></i>  </a>
							</li>
							<!-- /themify-link-item -->
							<li class="social-link-item instagram font-icon icon-medium">
								<a href="https://instagram.com/lkldnow" aria-label="instagram"><i class="fa fa-instagram" ></i>  </a>
							</li>
							<!-- /themify-link-item -->
							<li class="social-link-item twitter font-icon icon-medium">
								<a href="https://twitter.com/lkldnow" aria-label="twitter" ><i class="fa fa-twitter" ></i>  </a>
							</li>
							<!-- /themify-link-item -->
							<li class="social-link-item youtube font-icon icon-medium">
								<a href="https://www.youtube.com/c/lkldnow" aria-label="youtube" ><i class="fa fa-youtube" ></i>  </a>
							</li>
							<!-- /themify-link-item -->
							<li class="social-link-item email font-icon icon-medium">
								<a href="/cdn-cgi/l/email-protection#640a011317100d141724080f08000a0b134a070b09" aria-label="email"><i class="fa fa-envelope-o" ></i>  </a>
							</li>
							<!-- /themify-link-item --></ul></div>
											<div class="rss">
							<a href="https://www.lkldnow.com/feed/" class="hs-rss-link">
								<i class="fa fa-icon icon-rss"></i>
							</a>
						</div>
									</div>
				<!-- /.social-widget -->

									<div id="searchform-wrap">
						<div id="search-icon" class="mobile-button"></div>
						<form method="get" id="searchform" action="https://www.lkldnow.com/">
	<i class="fa fa-search icon-search"></i>
	<input type="text" name="s" id="s" placeholder="Search" />

</form>					</div>
					<!-- /#searchform-wrap -->
				
			</div>
		</div>
		<!-- /#nav-bar -->
    
		
		<header id="header" class="pagewidth clearfix">

			<!-- hook content: themify_header_start --><link rel="preload" href="https://www.lkldnow.com/wp-content/themes/magazine/themify/themify-builder/css/themify-builder-style.min.css?ver=4.9.2" as="style" data-no-minify="1" /><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
				if(document.getElementById( "themify-builder-style" )===null ){
					var el =  document.getElementById( "builder-styles-css" );
					if(el!==null){
					var link = document.createElement("link");
					link.id="themify-builder-style";
					link.rel="stylesheet";
					link.type="text/css";
					link.href=el.getAttribute("data-href");
					el.parentNode.replaceChild( link, el);
					}
				}
			</script><div class="themify_builder_content themify_builder_content-396344 themify_builder not_editable_builder" data-postid="396344">
    	<!-- module_row -->
	<div  class="themify_builder_row module_row clearfix module_row_0 themify_builder_396344_row module_row_396344-0 tb_noku373">
	    	    <div class="row_inner col_align_top" >
			<div  class="module_column tb-column col-full first tb_396344_column module_column_0 module_column_396344-0-0 tb_ru0w375">
	    	    	        <div class="tb-column-inner">
		        <!-- module image -->
    <div  class="module module-image tb_leob3  image-top donate-image  hide-tablet hide-mobile">
	                <div class="image-wrap">
                            <a href="/support_us/"
                                      >
                                           <img loading="lazy" src="https://www.lkldnow.com/wp-content/uploads/2019/05/donate-77x40.png" width="77" height="40" class=" wp-post-image wp-image-396345" title="donate" alt="donate" srcset="https://www.lkldnow.com/wp-content/uploads/2019/05/donate-77x40.png 77w, https://www.lkldnow.com/wp-content/uploads/2019/05/donate-115x60.png 115w, https://www.lkldnow.com/wp-content/uploads/2019/05/donate.png 192w" sizes="(max-width: 77px) 100vw, 77px" />                </a>
            
                        </div>
            <!-- /image-wrap -->
        
        
        </div>
    <!-- /module image -->
	        </div>
	    	</div>
		    </div>
	    <!-- /row_inner -->
	</div>
	<!-- /module_row -->
	</div>
<!-- /hook content: themify_header_start -->
			<div class="hgroup">
				<div id="site-logo"><a href="https://www.lkldnow.com" title="LkldNow"><img src="https://www.lkldnow.com/wp-content/uploads/2019/07/logowtagline24b.png" alt="LkldNow" title="logowtagline24b" /></a></div>			</div>

			<a id="menu-icon" href="#"><i class="fa fa-list-ul icon-list-ul"></i></a>
			<nav id="mobile-menu" class="sidemenu sidemenu-off" role="navigation">
				<ul id="main-nav" class="main-nav menu-name-main"><li id='menu-item-52843' class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home" ><a  href="https://www.lkldnow.com/">Home</a> </li>
<li id='menu-item-2687' class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children has-sub-menu" ><a  href="https://www.lkldnow.com/news/">News</a> 
<ul class="sub-menu">
<li id='menu-item-421420' class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children has-sub-menu" ><a  href="https://www.lkldnow.com/newsletters">Special Features</a> 
	<ul class="sub-menu">
<li id='menu-item-421419' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://www.lkldnow.com/newsletters/">Newsletters</a> </li>
<li id='menu-item-432993' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://www.lkldnow.com/newcomers/">Newcomers Guide</a> </li>
<li id='menu-item-415428' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://www.lkldnow.com/lkldnow-in-view/">LkldNow In View</a> </li>
<li id='menu-item-54232' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://www.lkldnow.com/weather/">Weather</a> </li>
	</ul>
</li>
<li id='menu-item-421421' class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children has-sub-menu" ><a  href="https://www.lkldnow.com/news/">Categories</a> 
	<ul class="sub-menu">
<li id='menu-item-52786' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="31" data-tax="category"><a  href="https://www.lkldnow.com/category/arts/">A &amp; E</a> </li>
<li id='menu-item-52785' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="72" data-tax="category"><a  href="https://www.lkldnow.com/category/business/">Business</a> </li>
<li id='menu-item-52779' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="32" data-tax="category"><a  href="https://www.lkldnow.com/category/city-hall/">City Hall</a> </li>
<li id='menu-item-425647' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://www.lkldnow.com/covid-19/">COVID-19</a> </li>
<li id='menu-item-52782' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="35" data-tax="category"><a  href="https://www.lkldnow.com/category/dining/">Dining</a> </li>
<li id='menu-item-52783' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="38" data-tax="category"><a  href="https://www.lkldnow.com/category/downtown/">Downtown</a> </li>
<li id='menu-item-52781' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="28" data-tax="category"><a  href="https://www.lkldnow.com/category/neighborhoods/">Neighborhoods</a> </li>
<li id='menu-item-52780' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="27" data-tax="category"><a  href="https://www.lkldnow.com/category/people/">People</a> </li>
<li id='menu-item-54930' class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent" data-termid="85" data-tax="category"><a  href="https://www.lkldnow.com/category/politics/">Politics</a> </li>
<li id='menu-item-52784' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="30" data-tax="category"><a  href="https://www.lkldnow.com/category/public-safety/">Public Safety</a> </li>
<li id='menu-item-53653' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="60" data-tax="category"><a  href="https://www.lkldnow.com/category/schools/">Schools</a> </li>
	</ul>
</li>
</ul>
</li>
<li id='menu-item-409228' class="menu-item menu-item-type-taxonomy menu-item-object-category" data-termid="245" data-tax="category"><a  href="https://www.lkldnow.com/category/obituaries/">Obituaries</a> </li>
<li id='menu-item-421246' class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children has-sub-menu" ><a  href="https://www.lkldnow.com/calendar/">Calendar</a> 
<ul class="sub-menu">
<li id='menu-item-421248' class="menu-item menu-item-type-custom menu-item-object-custom" ><a  href="https://www.lkldnow.com/calendar/#!/">All Events</a> </li>
<li id='menu-item-427082' class="menu-item menu-item-type-custom menu-item-object-custom" ><a  href="https://www.lkldnow.com/local-music/#!/show/?category=17&amp;view=list">Music Calendar</a> </li>
<li id='menu-item-421247' class="menu-item menu-item-type-custom menu-item-object-custom" ><a  href="https://portal.cityspark.com/add/event/LKLDNow">Add an event</a> </li>
</ul>
</li>
<li id='menu-item-52845' class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children has-sub-menu" ><a  href="https://www.lkldnow.com/lkld-maps/">Info Maps</a> 
<ul class="sub-menu">
<li id='menu-item-318971' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://www.lkldnow.com/weather/">Weather</a> </li>
<li id='menu-item-433187' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://www.lkldnow.com/lakeland-local-eats/">Locally Owned Restaurants</a> </li>
<li id='menu-item-318964' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://www.lkldnow.com/i-4-traffic-cameras/">I-4 Cameras</a> </li>
<li id='menu-item-318963' class="menu-item menu-item-type-custom menu-item-object-custom" ><a  href="https://lakelandelectric.com/storms-and-outages">Power Outages</a> </li>
<li id='menu-item-318965' class="menu-item menu-item-type-custom menu-item-object-custom" ><a  href="http://www.raidsonline.com/?address=Lakeland%2CFL">Crime</a> </li>
<li id='menu-item-318966' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://www.lkldnow.com/lkld-maps/">More Maps&#8230;</a> </li>
</ul>
</li>
</ul>				<!-- /#main-nav --> 
			</nav>

			
		</header>
		<!-- /#header -->

        				
	</div>
	<!-- /#headerwrap -->

	<div class="header-widget pagewidth">
			</div>
	<!--/header widget -->

		
	<div id="body" class="clearfix">

    <!-- hook content: themify_layout_before --> <center><broadstreet-zone zone-id="45237" keywords="not_home_page,not_landing_page,is_article_page,politics,republican-field-for-congressional-district-15-getting-more-crowded,post" soft-keywords="true" zone-alias=""></broadstreet-zone></center><!-- /hook content: themify_layout_before -->

<!-- layout-container -->
<div id="layout" class="pagewidth clearfix">

	<div id="contentwrap">

	
				<!-- content -->
		<div id="content" class="list-post">
			
			


<article itemscope itemtype="http://schema.org/Article" id="post-456458" class="post clearfix cat-85 post-456458 type-post status-publish format-standard hentry category-politics tag-curated has-post-title has-post-date has-post-category no-post-tag no-post-comment has-post-author ">
	
		
	
	<div class="post-content">

		                        <p class="post-meta entry-meta">
									<span class="post-category"><a href="https://www.lkldnow.com/category/politics/" rel="category tag">Politics</a></span>
							</p>
		
												<h1 class="post-title entry-title" itemprop="name"><a href="https://www.lkldnow.com/republican-field-for-congressional-district-15-getting-more-crowded/" title="Republican Field for Congressional District 15 Getting More Crowded">Republican Field for Congressional District 15 Getting More Crowded</a></h1>
						 
		
					<p class="post-meta entry-meta">

															<span class="author-avatar"><img alt='' src='https://secure.gravatar.com/avatar/12aa82b3036e8e95e0cb1c399167852f?s=30&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/12aa82b3036e8e95e0cb1c399167852f?s=60&#038;d=mm&#038;r=g 2x' itemprop='image' class='avatar avatar-30 photo' height='30' width='30' loading='lazy'/></span>
						<span class="author-name"><span class="author vcard"><a class="url fn n" href="https://www.lkldnow.com/author/barryf/" rel="author">Barry Friedman</a></span></span>
					
					
									
									 <time datetime="2022-05-03" class="post-date entry-date updated" itemprop="datePublished">May 3, 2022 at 3:00 pm</time> <span class="shortcode themify-icon "><a href="https://www.tampabay.com/news/florida-politics/2022/05/03/jay-collins-to-jump-to-red-leaning-15th-congressional-district/" class="themify-icon-link"><i class="themify-icon-icon fa fa-external-link-square"></i><span class="themify-icon-label">Tampa Bay Times</span></a></span>
	

		</p>	
		
					
<div class="share clearfix">

	
	
	
	
	
</div>
<!-- /.share -->
		
		
<div class="before-content-widget">

	
</div>
<!-- /before-content-widget -->		
		<div class="entry-content" itemprop="articleBody">

		
			
<p>Another Republican has joined the primary race to represent a U.S. House district that includes the western half of Lakeland. Previously, the District 15 primary battle had been between former U.S. Rep. Dennis Ross of Lakeland, former Florida Rep. Jackie Toledo of Tampa, and retired Navy Cmd. Demetries Grimes of Poinciana. Now Jay Collins of Tampa has entered the race, the <a href="https://www.tampabay.com/news/florida-politics/2022/05/03/jay-collins-to-jump-to-red-leaning-15th-congressional-district/" target="_blank" rel="noopener">Tampa Bay Times reports</a>. He had been considered the front-runner in the GOP primary to oppose Democratic District 14 incumbent Kathy Castor, but reapportionment left that district more Democrat-leaning and opened a vacancy in a Republican-leaning, redrawn 15th District.</p>


<div id="themify_builder_content-456458" data-postid="456458" class="themify_builder_content themify_builder_content-456458 themify_builder">
    </div>

<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-456458" class="share-facebook sd-button share-icon no-text" href="https://www.lkldnow.com/republican-field-for-congressional-district-15-getting-more-crowded/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-456458" class="share-twitter sd-button share-icon no-text" href="https://www.lkldnow.com/republican-field-for-congressional-district-15-getting-more-crowded/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-456458" class="share-pinterest sd-button share-icon no-text" href="https://www.lkldnow.com/republican-field-for-congressional-district-15-getting-more-crowded/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-456458" class="share-linkedin sd-button share-icon no-text" href="https://www.lkldnow.com/republican-field-for-congressional-district-15-getting-more-crowded/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://www.lkldnow.com/republican-field-for-congressional-district-15-getting-more-crowded/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.lkldnow.com/republican-field-for-congressional-district-15-getting-more-crowded/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://www.lkldnow.com/republican-field-for-congressional-district-15-getting-more-crowded/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>		
		
		</div><!-- /.entry-content -->
		
				
	</div>
	<!-- /.post-content -->
		
</article>
<!-- /.post -->


			
			
			
<div class="after-content-widget">

	
</div>
<!-- /after-content-widget -->			
			
			
							


			
					</div>
		<!-- /content -->
		
	
	</div>
	<!-- /#contentwrap -->

	    
    <aside id="sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSidebar">

            
            <div id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="47694" keywords="not_home_page,not_landing_page,is_article_page,politics,republican-field-for-congressional-district-15-getting-more-crowded,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="mo_optin_widgets-5" class="widget widget_mo_optin_widgets">
<!-- This site converts visitors into subscribers and customers with the MailOptin WordPress plugin v2.2.46.1 - https://mailoptin.io -->
<div id='hnBVXPlyCi' class="moOptinForm mo-optin-form-sidebar mo-has-email mo-optin-has-custom-field" data-optin-type='sidebar' style=''><div class='mo-optin-form-container' id='hnBVXPlyCi_sidebar_container' style='position:relative;margin: 0 auto;'><script type="text/javascript">var hnBVXPlyCi = hnBVXPlyCi_sidebar = {"optin_uuid":"hnBVXPlyCi","optin_campaign_id":8,"optin_campaign_name":"Multiple choice widget - blue","optin_type":"sidebar","post_id":456458,"cookie":30,"success_cookie":30,"global_cookie":0,"global_success_cookie":0,"success_message":"Thanks for subscribing!","name_field_required":true,"is_split_test":false,"required_custom_fields":[],"success_action":"success_message","state_after_conversion":"success_message_shown","test_mode":false,"icon_close":false,"unexpected_error":"Unexpected error. Please try again.","email_missing_error":"Please enter a valid email.","name_missing_error":"Please enter a name.","custom_field_required_error":"A required field is empty.","note_acceptance_error":"Please accept our terms.","honeypot_error":"Your submission has been flagged as potential spam.","mailchimp_segment_required":true,"mailchimp_segment_required_error":"You did not check one of the boxes.","effects":"","ga_active":true,"device_targeting_hide_desktop":false,"device_targeting_hide_tablet":false,"device_targeting_hide_mobile":false};</script><style id="mo-optin-form-stylesheet" type="text/css">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</style><div id="hnBVXPlyCi_sidebar" class="mo-optin-form-wrapper mo-has-email lupinSidebar-container" style="position: relative;margin-right: auto;margin-left: auto;background-color: #0087c0;border-color: #0087c0;line-height: normal;"><form method="post" class='mo-optin-form' id='hnBVXPlyCi_sidebar_form' style='margin:0;'><h2 class="mo-optin-form-headline lupinSidebar-heading" style="color: #ffffff;font-family: 'Open Sans', Helvetica, Arial, sans-serif; padding: 0;">KEEP UP WITH LAKELAND</h2><div class="mo-optin-form-description lupinSidebar-description" style="color: #ffffff;font-family: 'Open Sans', Helvetica, Arial, sans-serif;"><p><strong>Get LkldNow news via email.</strong></p><p>Always free. Choose how often.</p></div><div class="lupinSidebar-form"><div class="mo-optin-error " style=''>Invalid email address</div><div class="mo-optin-fields-wrapper" style=""><input id="hnBVXPlyCi_sidebar_name_field" class="mo-optin-field mo-optin-form-name-field lupinSidebar-input" style='color: #555555;height: auto;font-family: Palatino Linotype, Book Antiqua, serif;display: none;' type="text" placeholder="Enter your name here..." name="mo-name" autocomplete="on" value=""> <input id="hnBVXPlyCi_sidebar_email_field" class="mo-optin-field mo-optin-form-email-field lupinSidebar-input" style="color: #808080;height: auto;font-family: Palatino Linotype, Book Antiqua, serif;" type="email" placeholder="Your email address" name="mo-email" autocomplete="on" value=""> <div class='mo-mailchimp-interest-container' style='text-align:left;color:#ffffff;font-family: "Open Sans"'><div class="mo-mailchimp-interest-label">Select one or more:</div><div class='mo-mailchimp-interest-choice-container' style='display:block;'><label><input type='checkbox' class='mo-mailchimp-interest-choice' name='mo-mailchimp-interests[]' value='d04089e7ca'/><span class='mo-mailchimp-choice-label'>Weekly, our premium newsletter</span></label></div><div class='mo-mailchimp-interest-choice-container' style='display:block;'><label><input type='checkbox' class='mo-mailchimp-interest-choice' name='mo-mailchimp-interests[]' value='9945e410fa'/><span class='mo-mailchimp-choice-label'>Instant news alerts</span></label></div><div class='mo-mailchimp-interest-choice-container' style='display:block;'><label><input type='checkbox' class='mo-mailchimp-interest-choice' name='mo-mailchimp-interests[]' value='efded7c32f'/><span class='mo-mailchimp-choice-label'>Daily summary</span></label></div></div><input id="hnBVXPlyCi_sidebar_submit_button" class="mo-optin-form-submit-button lupinSidebar-submit" style="background: #f7a92c;color: #ffffff;height: auto;text-shadow: none;font-family: 'Open Sans', Helvetica, Arial, sans-serif;" type="submit" value="Sign up"> </div><input id="hnBVXPlyCi_sidebar_cta_button" class="mo-optin-form-cta-button " style="background: #FEC32D;color: #ffffff;height: auto;text-shadow: none;font-family: 'Open Sans', Helvetica, Arial, sans-serif;display: none;" type="submit" value="Take Action Now!"> </div><div class="mo-optin-form-note lupinSidebar-note" style="color: #ffffff;font-family: 'Open Sans', Helvetica, Arial, sans-serif;"><span class="mo-note-content"><em>We promise not to spam you. You can unsubscribe at any time.</em></span></div><input id='hnBVXPlyCi_sidebar_honeypot_email_field' type='text' name='mo-hp-email' value='' style='display:none'/><input id="hnBVXPlyCi_sidebar_honeypot_website_field" type="text" name="mo-hp-website" value="" style="display:none"/></form><div class='mo-optin-spinner' style='display:none'></div><div class="mo-optin-success-msg" style="display:none">Thanks for subscribing!</div></div></div><input id="hnBVXPlyCi_sidebar_honeypot_timestamp" type="hidden" name="mo-timestamp" value="1651621066" style="display:none"/></div><!-- / MailOptin WordPress plugin. -->
<script type='text/javascript'>jQuery(function(){if(typeof WebFont!=='undefined'){WebFont.load({google: {families: ['Open Sans:400,700',]}});}});</script></div><div id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div data-cswidget="10018"> </div>
<script type="text/javascript" async defer src="//cdn.cityspark.com/wid/get.js" > </script></div></div><div id="custom_html-4" class="widget_text widget widget_custom_html"><h4 class="widgettitle">Coronavirus</h4><div class="textwidget custom-html-widget"><img src="https://www.lkldnow.com/wp-content/uploads/2020/03/local-resources.jpg" width="300" height="79" alt="local resources"><br>
<ul>
	<li>
<a href="https://www.lkldnow.com/covid-19/">Local data and LkldNow coverage</a>
</li>
<li>
<a href="https://floridahealthcovid19.gov/#latest-stats/">Florida current situation</a>
</li>
<li><a href="https://floridahealthcovid19.gov/vaccines/vaccine-locator/">Vaccine sites</a></li>
</ul></div></div><style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 700;
font-size: 14px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><div id="rpwe_widget-3" class="widget rpwe_widget recent-posts-extended"><h4 class="widgettitle">LKLDNOW ORIGINALS</h4><div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.lkldnow.com/bodega-market-set-to-open-on-munn-park-by-thanksgiving/"><img class="rpwe-alignleft rpwe-thumb" src="https://www.lkldnow.com/wp-content/uploads/2022/05/bodega-market-sm-45x45.jpg" alt="Bodega Market Set to Open on Munn Park by Thanksgiving" height="45" width="45"></a><h3 class="rpwe-title"><a href="https://www.lkldnow.com/bodega-market-set-to-open-on-munn-park-by-thanksgiving/" title="Permalink to Bodega Market Set to Open on Munn Park by Thanksgiving" rel="bookmark">Bodega Market Set to Open on Munn Park by Thanksgiving</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.lkldnow.com/lakeland-company-debuts-its-vegan-cupcakes-in-publix-greenwise-markets/"><img class="rpwe-alignleft rpwe-thumb" src="https://www.lkldnow.com/wp-content/uploads/2022/05/mike-and-mikes-sq-45x45.jpg" alt="Lakeland Company Debuts Its Vegan Cupcakes in Publix GreenWise Markets" height="45" width="45"></a><h3 class="rpwe-title"><a href="https://www.lkldnow.com/lakeland-company-debuts-its-vegan-cupcakes-in-publix-greenwise-markets/" title="Permalink to Lakeland Company Debuts Its Vegan Cupcakes in Publix GreenWise Markets" rel="bookmark">Lakeland Company Debuts Its Vegan Cupcakes in Publix GreenWise Markets</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.lkldnow.com/city-oks-7-story-downtown-apartment-complex-parking-garage/"><img class="rpwe-alignleft rpwe-thumb" src="https://www.lkldnow.com/wp-content/uploads/2022/05/oak-street-development-concept-sq-45x45.jpg" alt="City OKs 7-Story Downtown Apartment Complex, Parking  Garage" height="45" width="45"></a><h3 class="rpwe-title"><a href="https://www.lkldnow.com/city-oks-7-story-downtown-apartment-complex-parking-garage/" title="Permalink to City OKs 7-Story Downtown Apartment Complex, Parking  Garage" rel="bookmark">City OKs 7-Story Downtown Apartment Complex, Parking  Garage</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.lkldnow.com/survey-and-public-forum-in-june-will-collect-comments-on-south-florida-avenue-road-diet/"><img class="rpwe-alignleft rpwe-thumb" src="https://www.lkldnow.com/wp-content/uploads/2021/08/road-diet-sq-45x45.jpg" alt="Survey and Public Forum in June Will Collect Comments on South Florida Avenue Road Diet" height="45" width="45"></a><h3 class="rpwe-title"><a href="https://www.lkldnow.com/survey-and-public-forum-in-june-will-collect-comments-on-south-florida-avenue-road-diet/" title="Permalink to Survey and Public Forum in June Will Collect Comments on South Florida Avenue Road Diet" rel="bookmark">Survey and Public Forum in June Will Collect Comments on South Florida Avenue Road Diet</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.lkldnow.com/wedgewood-golf-course-sold-1400-residences-planned/"><img class="rpwe-alignleft rpwe-thumb" src="https://www.lkldnow.com/wp-content/uploads/2022/04/gibson-trails-sm-45x45.jpg" alt="Wedgewood Golf Course Sold; 1,400 Residences Planned" height="45" width="45"></a><h3 class="rpwe-title"><a href="https://www.lkldnow.com/wedgewood-golf-course-sold-1400-residences-planned/" title="Permalink to Wedgewood Golf Course Sold; 1,400 Residences Planned" rel="bookmark">Wedgewood Golf Course Sold; 1,400 Residences Planned</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --><a href="/tag/lkldnow/">More 
 &gt;</a></div>    <style>
        .rpwe-block ul {
            list-style: none !important;
            margin-left: 0 !important;
            padding-left: 0 !important;
        }

        .rpwe-block li {
            border-bottom: 1px solid #eee;
            margin-bottom: 10px;
            padding-bottom: 10px;
            list-style-type: none;
        }

        .rpwe-block a {
            display: inline !important;
            text-decoration: none;
        }

        .rpwe-block h3 {
            background: none !important;
            clear: none;
            margin-bottom: 0 !important;
            margin-top: 0 !important;
            font-weight: 400;
            font-size: 12px !important;
            line-height: 1.5em;
        }

        .rpwe-thumb {
            border: 1px solid #EEE !important;
            box-shadow: none !important;
            margin: 2px 10px 2px 0;
            padding: 3px !important;
        }

        .rpwe-summary {
            font-size: 12px;
        }

        .rpwe-time {
            color: #bbb;
            font-size: 11px;
        }

        .rpwe-comment {
            color: #bbb;
            font-size: 11px;
            padding-left: 5px;
        }

        .rpwe-alignleft {
            display: inline;
            float: left;
        }

        .rpwe-alignright {
            display: inline;
            float: right;
        }

        .rpwe-aligncenter {
            display: block;
            margin-left: auto;
            margin-right: auto;
        }

        .rpwe-clearfix:before,
        .rpwe-clearfix:after {
            content: "";
            display: table !important;
        }

        .rpwe-clearfix:after {
            clear: both;
        }

        .rpwe-clearfix {
            zoom: 1;
        }
    </style>
<div id="rpwe_widget-4" class="widget rpwe_widget recent-posts-extended"><h4 class="widgettitle">Obituaries</h4><div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.lkldnow.com/james-boyd-stafford-64/"><img class="rpwe-alignleft rpwe-thumb" src="https://www.lkldnow.com/wp-content/uploads/2022/04/Stafford-pnk1nc9a0fcdyrgveogca14wan7sq8i5fwfzuzuamc-45x45.jpeg" alt="James Boyd Stafford, 64" height="45" width="45"></a><h3 class="rpwe-title"><a href="https://www.lkldnow.com/james-boyd-stafford-64/" title="Permalink to James Boyd Stafford, 64" rel="bookmark">James Boyd Stafford, 64</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.lkldnow.com/william-richard-fontaine-83/"><img class="rpwe-alignleft rpwe-thumb" src="https://www.lkldnow.com/wp-content/uploads/2022/04/Fontaine-pnlpxak7flugffhoeniqgg95hbsmff2eg65c36fi9w-45x45.jpg" alt="William Richard Fontaine, 83" height="45" width="45"></a><h3 class="rpwe-title"><a href="https://www.lkldnow.com/william-richard-fontaine-83/" title="Permalink to William Richard Fontaine, 83" rel="bookmark">William Richard Fontaine, 83</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.lkldnow.com/donald-l-metzger-88/"><img class="rpwe-alignleft rpwe-thumb" src="https://www.lkldnow.com/wp-content/uploads/2022/04/DMetzger-pnb2emb11xjtgagdon4vuimq3v4ruzj1jhaqa9q1qc-45x45.jpg" alt="Donald L Metzger, 88" height="45" width="45"></a><h3 class="rpwe-title"><a href="https://www.lkldnow.com/donald-l-metzger-88/" title="Permalink to Donald L Metzger, 88" rel="bookmark">Donald L Metzger, 88</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.lkldnow.com/barbara-lynn-kinard-84/"><img class="rpwe-alignleft rpwe-thumb" src="https://www.lkldnow.com/wp-content/uploads/2022/04/Screenshot-2022-04-29-213625-45x45.jpg" alt="Barbara Lynn Kinard, 84" height="45" width="45"></a><h3 class="rpwe-title"><a href="https://www.lkldnow.com/barbara-lynn-kinard-84/" title="Permalink to Barbara Lynn Kinard, 84" rel="bookmark">Barbara Lynn Kinard, 84</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.lkldnow.com/judith-barbara-tabler-82/" title="Permalink to Judith Barbara Tabler, 82" rel="bookmark">Judith Barbara Tabler, 82</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></div>
            <div class="clearfix">

                    <div class="secondary">
                                                </div>

                    <div class="secondary last">
                                                </div>

            </div>

            
            
    </aside>
    <!-- /#sidebar -->

    
</div>
<!-- /layout-container -->
	

	    </div>
	<!-- /body -->
		
	<div id="footerwrap">
    
    			<footer id="footer" class="pagewidth clearfix">
			
			<p class="back-top">
				<a href="#header">Back to Top</a>
			</p>

			
	<div class="footer-widgets clearfix">

								<div class="col4-2 first">
				<div id="mo_optin_widgets-4" class="widget widget_mo_optin_widgets"><h4 class="widgettitle">Get LkldNow News By Email</h4>
<!-- This site converts visitors into subscribers and customers with the MailOptin WordPress plugin v2.2.46.1 - https://mailoptin.io -->
<div id='MVHbkNsfzh' class="moOptinForm mo-optin-form-sidebar mo-has-email mo-optin-has-custom-field" data-optin-type='sidebar' style=''><div class='mo-optin-form-container' id='MVHbkNsfzh_sidebar_container' style='position:relative;margin: 0 auto;'><script type="text/javascript">var MVHbkNsfzh = MVHbkNsfzh_sidebar = {"optin_uuid":"MVHbkNsfzh","optin_campaign_id":9,"optin_campaign_name":"Multichoice simple footer widget","optin_type":"sidebar","post_id":456458,"cookie":30,"success_cookie":30,"global_cookie":0,"global_success_cookie":0,"success_message":"Thanks for subscribing!","name_field_required":true,"is_split_test":false,"required_custom_fields":[],"success_action":"success_message","state_after_conversion":"success_message_shown","test_mode":false,"icon_close":false,"unexpected_error":"Unexpected error. Please try again.","email_missing_error":"Please enter a valid email.","name_missing_error":"Please enter a name.","custom_field_required_error":"A required field is empty.","note_acceptance_error":"Please accept our terms.","honeypot_error":"Your submission has been flagged as potential spam.","mailchimp_segment_required":true,"mailchimp_segment_required_error":"Please select at least one box","effects":"","ga_active":true,"device_targeting_hide_desktop":false,"device_targeting_hide_tablet":false,"device_targeting_hide_mobile":false};</script><style id="mo-optin-form-stylesheet" type="text/css">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</style><div id="MVHbkNsfzh_sidebar" class="mo-optin-form-wrapper mo-has-email quince-container" style="position: relative;margin-right: auto;margin-left: auto;background-color: #070707;border-color: #070707;line-height: normal;"><form method="post" class='mo-optin-form' id='MVHbkNsfzh_sidebar_form' style='margin:0;'><div class="quince-container_inner"><div class="quince-container_right-section"><div class="quince-container_right-section_inner"><div class="mo-optin-form-headline quince-headline" style="color: #273238;font-family: 'Open Sans', Helvetica, Arial, sans-serif;display: none;">Sign up Now (For Free)</div><div class="mo-optin-form-description quince-description" style="color: #444444;font-family: Arial, Helvetica, Arial, sans-serif;display: none;"><p style="text-align: left;"><span style="color: #999999; font-family: Helvetica, Arial, sans-serif; background-color: #000000;">Always free. Choose how often.</span></p></div><input id="MVHbkNsfzh_sidebar_cta_button" class="mo-optin-form-cta-button quince-cta-btn" style="background: #1342a1d6;color: #ffffff;height: auto;text-shadow: none;font-family: 'Open Sans', Helvetica, Arial, sans-serif;display: none;" type="submit" value="Take Action Now!"> <div class="mo-optin-fields-wrapper quince-container_field" style=""><div class="mo-optin-error " style=''>Invalid email address</div><input id="MVHbkNsfzh_sidebar_name_field" class="mo-optin-field mo-optin-form-name-field quince-fields quince-field" style='color: #444444;background-color: #ffffff;height: auto;font-family: Open Sans;display: none;' type="text" placeholder="Enter your name" name="mo-name" autocomplete="on" value=""> <input id="MVHbkNsfzh_sidebar_email_field" class="mo-optin-field mo-optin-form-email-field quince-fields quince-field" style="color: #444444;background-color: #ffffff;height: auto;font-family: Open Sans;" type="email" placeholder="Your email address" name="mo-email" autocomplete="on" value=""> <input type="hidden" name="mo-list-subscription-integration" value="MailChimpConnect"> <div class='mo-mailchimp-interest-container' style='text-align:left;color:#aaaaaa;'><div class="mo-mailchimp-interest-label">Always free. Select one or more:</div><div class='mo-mailchimp-interest-choice-container' style='display:inline;'><label><input type='checkbox' class='mo-mailchimp-interest-choice' name='mo-mailchimp-interests[]' value='d04089e7ca'/><span class='mo-mailchimp-choice-label'>Weekly, our premium newsletter</span></label></div><div class='mo-mailchimp-interest-choice-container' style='display:inline;'><label><input type='checkbox' class='mo-mailchimp-interest-choice' name='mo-mailchimp-interests[]' value='9945e410fa'/><span class='mo-mailchimp-choice-label'>Instant news alerts</span></label></div><div class='mo-mailchimp-interest-choice-container' style='display:inline;'><label><input type='checkbox' class='mo-mailchimp-interest-choice' name='mo-mailchimp-interests[]' value='efded7c32f'/><span class='mo-mailchimp-choice-label'>Daily summary</span></label></div></div><input id="MVHbkNsfzh_sidebar_submit_button" class="mo-optin-form-submit-button quince-fields quince-submit_btn" style="background: #0087c0;color: #ffffff;height: auto;text-shadow: none;font-family: 'Source Sans Pro', Helvetica, Arial, sans-serif;" type="submit" value="SIGN UP"> </div><div class="mo-optin-form-note quince-note" style="color: #7a7a7a;font-family: 'Open Sans', Helvetica, Arial, sans-serif;display: none;"><span class="mo-note-content">We promise not to spam you. You can unsubscribe at any time.</span></div></div></div></div><input id='MVHbkNsfzh_sidebar_honeypot_email_field' type='text' name='mo-hp-email' value='' style='display:none'/><input id="MVHbkNsfzh_sidebar_honeypot_website_field" type="text" name="mo-hp-website" value="" style="display:none"/></form><div class='mo-optin-spinner' style='display:none'></div><div class="mo-optin-success-msg" style="display:none">Thanks for subscribing!</div></div></div><input id="MVHbkNsfzh_sidebar_honeypot_timestamp" type="hidden" name="mo-timestamp" value="1651621067" style="display:none"/></div><!-- / MailOptin WordPress plugin. -->
<script type='text/javascript'>jQuery(function(){if(typeof WebFont!=='undefined'){WebFont.load({google: {families: ['Open Sans:400,700','Source Sans Pro:400,700','Arial, Helvetica, sans-serif:400,700',]}});}});</script></div>			</div>
								<div class="col4-2 ">
				<div id="text-1007" class="widget widget_text"><h4 class="widgettitle">Contact us</h4>			<div class="textwidget"><p>Send tips, feedback, corrections to <a href="/cdn-cgi/l/email-protection#0b656e7c787f627b784b6760676f65647c25686466"><span class="__cf_email__" data-cfemail="adc3c8daded9c4dddeedc1c6c1c9c3c2da83cec2c0">[email&#160;protected]</span></a></p>
</div>
		</div><div id="media_gallery-2" class="widget widget_media_gallery"><h4 class="widgettitle">Proud Member</h4><div class="tiled-gallery type-rectangular tiled-gallery-unresized" data-original-width="1165" data-carousel-extra='{&quot;blog_id&quot;:1,&quot;permalink&quot;:&quot;https:\/\/www.lkldnow.com\/republican-field-for-congressional-district-15-getting-more-crowded\/&quot;,&quot;likes_blog_id&quot;:104582204}' itemscope itemtype="http://schema.org/ImageGallery" > <div class="gallery-row" style="width: 1165px; height: 200px;" data-original-width="1165" data-original-height="200" > <div class="gallery-group images-1" style="width: 591px; height: 200px;" data-original-width="591" data-original-height="200" > <div class="tiled-gallery-item tiled-gallery-item-large" itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject"> <a href="https://www.lkldnow.com/inn-logo-primary-white-480x160-1/" border="0" itemprop="url"> <meta itemprop="width" content="587"> <meta itemprop="height" content="196"> <img data-attachment-id="419091" data-orig-file="https://www.lkldnow.com/wp-content/uploads/2020/12/INN-Logo-Primary-White-480x160-1.png" data-orig-size="480,160" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Institute for Nonprofit News" data-image-description="" data-medium-file="https://www.lkldnow.com/wp-content/uploads/2020/12/INN-Logo-Primary-White-480x160-1-300x100.png" data-large-file="https://www.lkldnow.com/wp-content/uploads/2020/12/INN-Logo-Primary-White-480x160-1.png" src="https://i0.wp.com/www.lkldnow.com/wp-content/uploads/2020/12/INN-Logo-Primary-White-480x160-1.png?w=587&#038;h=196&#038;ssl=1" width="587" height="196" data-original-width="587" data-original-height="196" itemprop="http://schema.org/image" title="Institute for Nonprofit News" alt="Institute for Nonprofit News" style="width: 587px; height: 196px;" /> </a> </div> </div> <!-- close group --> <div class="gallery-group images-1" style="width: 574px; height: 200px;" data-original-width="574" data-original-height="200" > <div class="tiled-gallery-item tiled-gallery-item-large" itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject"> <a href="https://www.lkldnow.com/updated-website-logo-options-3_white/" border="0" itemprop="url"> <meta itemprop="width" content="570"> <meta itemprop="height" content="196"> <img data-attachment-id="419092" data-orig-file="https://www.lkldnow.com/wp-content/uploads/2020/12/Updated-website-logo-options-3_white.png" data-orig-size="300,103" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="LION Publishers" data-image-description="" data-medium-file="https://www.lkldnow.com/wp-content/uploads/2020/12/Updated-website-logo-options-3_white.png" data-large-file="https://www.lkldnow.com/wp-content/uploads/2020/12/Updated-website-logo-options-3_white.png" src="https://i0.wp.com/www.lkldnow.com/wp-content/uploads/2020/12/Updated-website-logo-options-3_white.png?w=570&#038;h=196&#038;ssl=1" width="570" height="196" data-original-width="570" data-original-height="196" itemprop="http://schema.org/image" title="LION Publishers" alt="LION Publishers" style="width: 570px; height: 196px;" /> </a> </div> </div> <!-- close group --> </div> <!-- close row --> </div></div>			</div>
		
	</div>
	<!-- /.footer-widgets -->


			<div class="social-widget">
				<div id="themify-social-links-1014" class="widget themify-social-links"><ul class="social-links horizontal">
							<li class="social-link-item facebook font-icon icon-large">
								<a href="https://www.facebook.com/lkldnow" aria-label="facebook" ><i class="fa fa-facebook" ></i>  </a>
							</li>
							<!-- /themify-link-item -->
							<li class="social-link-item instagram font-icon icon-large">
								<a href="https://instagram.com/lkldnow" aria-label="instagram"><i class="fa fa-instagram" ></i>  </a>
							</li>
							<!-- /themify-link-item -->
							<li class="social-link-item twitter font-icon icon-large">
								<a href="https://twitter.com/lkldnow" aria-label="twitter" ><i class="fa fa-twitter" ></i>  </a>
							</li>
							<!-- /themify-link-item -->
							<li class="social-link-item youtube font-icon icon-large">
								<a href="https://www.youtube.com/c/lkldnow" aria-label="youtube" ><i class="fa fa-youtube" ></i>  </a>
							</li>
							<!-- /themify-link-item -->
							<li class="social-link-item email font-icon icon-large">
								<a href="/cdn-cgi/l/email-protection#a6c8c3d1d5d2cfd6d5e6cacdcac2c8c9d188c5c9cb" aria-label="email"><i class="fa fa-envelope-o" ></i>  </a>
							</li>
							<!-- /themify-link-item --></ul></div>			</div>
			<!-- /.social-widget -->

			<div class="footer-nav-wrap">
							</div>
	
			<div class="footer-text clearfix">
				 <div class="one"><a href="/terms-of-service/">Terms of Service</a> | <a href="/privacy-policy/">Privacy Policy</a> <br>Lakeland, Florida</div>				 Copyright &copy; 2022 Linking Community Now, Inc.
			</div>
			<!-- /footer-text --> 
			<!-- hook content: themify_footer_end --><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
//<![CDATA[
jQuery(document).ready(function($) {
$('a').each(function() {
var a = new RegExp('/' + window.location.host + '/');
if(!a.test(this.href)) {
$(this).click(function(event) {
event.preventDefault();
event.stopPropagation();
window.open(this.href, '_blank');
});
}
});
});
//]]>
</script><!-- /hook content: themify_footer_end -->
		</footer>
		<!-- /#footer --> 
        <!-- hook content: themify_footer_after --><script>
function init() {
var vidDefer = document.getElementsByTagName('iframe');
for (var i=0; i<vidDefer.length; i++) {
if(vidDefer[i].getAttribute('data-src')) {
vidDefer[i].setAttribute('src',vidDefer[i].getAttribute('data-src'));
} } }
window.onload = init;
</script><!-- /hook content: themify_footer_after -->	</div>
	<!-- /#footerwrap -->
	
</div>
<!-- /#pagewrap -->


<!-- SCHEMA BEGIN --><script type="application/ld+json">[{"@context":"https:\/\/schema.org","@type":"BlogPosting","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.lkldnow.com\/republican-field-for-congressional-district-15-getting-more-crowded\/"},"headline":"Republican Field for Congressional District 15 Getting More Crowded","datePublished":"2022-05-03T15:00:30-04:00","dateModified":"2022-05-03T15:00:30-04:00","author":{"@type":"Person","name":"Barry Friedman"},"publisher":{"@type":"Organization","name":"","logo":{"@type":"ImageObject","url":"","width":0,"height":0}},"description":"Another Republican has joined the primary race to represent a U.S. House district that includes the western half of Lakeland. Previously, the District 15 primary battle had been between former U.S. Rep. Dennis Ross of Lakeland, former Florida Rep. Jackie Toledo of Tampa, and retired Navy Cmd. Demetries Grimes of Poinciana. Now Jay Collins of [&hellip;]"}]</script><!-- /SCHEMA END --><!-- wp_footer -->


<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','politics','republican-field-for-congressional-district-15-getting-more-crowded','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["politics","republican-field-for-congressional-district-15-getting-more-crowded","post"],"url":"republican-field-for-congressional-district-15-getting-more-crowded"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.watch({});
 });</script>			<script>
				// Used by Gallery Custom Links to handle tenacious Lightboxes
				jQuery(document).ready(function () {

					function mgclInit() {
						if (jQuery.fn.off) {
							jQuery('.no-lightbox, .no-lightbox img').off('click'); // jQuery 1.7+
						}
						else {
							jQuery('.no-lightbox, .no-lightbox img').unbind('click'); // < jQuery 1.7
						}
						jQuery('a.no-lightbox').click(mgclOnClick);

						if (jQuery.fn.off) {
							jQuery('a.set-target').off('click'); // jQuery 1.7+
						}
						else {
							jQuery('a.set-target').unbind('click'); // < jQuery 1.7
						}
						jQuery('a.set-target').click(mgclOnClick);
					}

					function mgclOnClick() {
						if (!this.target || this.target == '' || this.target == '_self')
							window.location = this.href;
						else
							window.open(this.href,this.target);
						return false;
					}

					// From WP Gallery Custom Links
					// Reduce the number of  conflicting lightboxes
					function mgclAddLoadEvent(func) {
						var oldOnload = window.onload;
						if (typeof window.onload != 'function') {
							window.onload = func;
						} else {
							window.onload = function() {
								oldOnload();
								func();
							}
						}
					}

					mgclAddLoadEvent(mgclInit);
					mgclInit();

				});
			</script>
		<!-- Universal Google Analytics -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-64056342-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- End Universal Google Analytics -->

<!-- GTM Container placement set to footer -->
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MHLDLMK"
height="0" width="0" style="display:none;visibility:hidden" aria-hidden="true"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.lkldnow.com\/republican-field-for-congressional-district-15-getting-more-crowded\/":456458};
	</script>
							<div id="sharing_email" style="display: none;">
		<form action="/republican-field-for-congressional-district-15-getting-more-crowded/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://www.lkldnow.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay" style="display: none;">

		<div class="jp-carousel-container">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
												<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<form id="jp-carousel-comment-form">
												<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
												<textarea
													name="comment"
													class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
													id="jp-carousel-comment-form-comment-field"
													placeholder="Write a Comment..."
												></textarea>
												<div id="jp-carousel-comment-form-submit-and-info-wrapper">
													<div id="jp-carousel-comment-form-commenting-as">
																													<fieldset>
																<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
																<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
																<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-url-field">Website</label>
																<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
															</fieldset>
																											</div>
													<input
														type="submit"
														name="submit"
														class="jp-carousel-comment-form-button"
														id="jp-carousel-comment-form-button-submit"
														value="Post Comment" />
												</div>
											</form>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		<!-- `jetpack-carousel-swiper-css` is included in the concatenated jetpack.css -->
<!-- `jetpack-carousel` is included in the concatenated jetpack.css -->
<!-- `tiled-gallery` is included in the concatenated jetpack.css -->
<script type='text/javascript' id='themify-main-script-js-extra'>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</script>
<script type='text/javascript' defer="defer" src='https://www.lkldnow.com/wp-content/themes/magazine/themify/js/main.min.js?ver=4.9.2' id='themify-main-script-js'></script>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js?ver=2.2.46.1' id='mo-google-webfont-js'></script>
<script type='text/javascript' id='mailoptin-js-extra'>
/* <![CDATA[ */
var mailoptin_globals = {"public_js":"https:\/\/www.lkldnow.com\/wp-content\/plugins\/mailoptin\/src\/core\/src\/assets\/js\/src","public_sound":"https:\/\/www.lkldnow.com\/wp-content\/plugins\/mailoptin\/src\/core\/src\/assets\/sound\/","mailoptin_ajaxurl":"\/republican-field-for-congressional-district-15-getting-more-crowded\/?mailoptin-ajax=%%endpoint%%","is_customize_preview":"false","disable_impression_tracking":"false","sidebar":"0","js_required_title":"Title is required.","is_new_returning_visitors_cookies":"true"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.lkldnow.com/wp-content/plugins/mailoptin/src/core/src/assets/js/mailoptin.min.js?ver=2.2.46.1' id='mailoptin-js'></script>
<script type='text/javascript' defer="defer" src='https://www.lkldnow.com/wp-content/themes/magazine/js/jquery.scroll.min.js?ver=5.9.3' id='theme-scroll-js'></script>
<script type='text/javascript' defer="defer" src='https://www.lkldnow.com/wp-content/themes/magazine/js/themify.sidemenu.min.js?ver=5.9.3' id='slide-nav-js'></script>
<script type='text/javascript' id='theme-script-js-extra'>
/* <![CDATA[ */
var themifyScript = {"themeURI":"https:\/\/www.lkldnow.com\/wp-content\/themes\/magazine","lightbox":{"lightboxSelector":".themify_lightbox","lightboxOn":true,"lightboxContentImages":false,"lightboxContentImagesSelector":"","theme":"pp_default","social_tools":false,"allow_resize":true,"show_title":false,"overlay_gallery":false,"screenWidthNoLightbox":600,"deeplinking":false,"contentImagesAreas":"","gallerySelector":".gallery-icon > a","lightboxGalleryOn":true},"fixedHeader":"fixed-header","ajax_nonce":"d4a4f2decb","ajax_url":"https:\/\/www.lkldnow.com\/wp-admin\/admin-ajax.php","events":"mouseenter","top_nav_side":"left","main_nav_side":"right"};
/* ]]> */
</script>
<script type='text/javascript' defer="defer" src='https://www.lkldnow.com/wp-content/themes/magazine/js/themify.script.min.js?ver=5.9.3' id='theme-script-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackSwiperLibraryPath = {"url":"https:\/\/www.lkldnow.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.lkldnow.com\/wp-admin\/admin-ajax.php","nonce":"ee2870918f","display_exif":"0","display_comments":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.lkldnow.com\/wp-login.php?redirect_to=https%3A%2F%2Fwww.lkldnow.com%2Frepublican-field-for-congressional-district-15-getting-more-crowded%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.lkldnow.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=10.8' id='jetpack-carousel-js'></script>
<script type='text/javascript' src='https://www.lkldnow.com/wp-content/plugins/jetpack/_inc/build/tiled-gallery/tiled-gallery/tiled-gallery.min.js?ver=5.9.3' id='tiled-gallery-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.lkldnow.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=10.8' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-tumblr' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-tumblr' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
						return false;
					}
				} );
			} )();
</script>
<script src='https://stats.wp.com/e-202218.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.8',blog:'104582204',post:'456458',tz:'-4',srv:'www.lkldnow.com'} ]);
	_stq.push([ 'clickTrackerInit', '104582204', '456458' ]);
</script>

<!-- This site converts visitors into subscribers and customers with the MailOptin WordPress plugin v2.2.46.1 - https://mailoptin.io -->
<div id='dxxMrRjcGP' class="moOptinForm mo-optin-form-slidein mo-has-email mo-slidein-bottom_right" data-optin-type='slidein' style='display: none;position: fixed;bottom: 10px;width: 100%;margin: 0;z-index: 999999999'><div class='mo-optin-form-container' id='dxxMrRjcGP_slidein_container' style='position:relative;margin: 0 auto;'><script type="text/javascript">var dxxMrRjcGP = dxxMrRjcGP_slidein = {"optin_uuid":"dxxMrRjcGP","optin_campaign_id":11,"optin_campaign_name":"Slide In Email Sign Ups 7.21 - Desktop","optin_type":"slidein","post_id":456458,"cookie":7,"success_cookie":90,"global_cookie":0,"global_success_cookie":0,"success_message":"Thanks for subscribing!","name_field_required":true,"is_split_test":false,"x_scroll_status":true,"x_scroll_value":20,"success_action":"success_message","state_after_conversion":"success_message_shown","test_mode":false,"icon_close":false,"slidein_position":"bottom_right","unexpected_error":"Unexpected error. Please try again.","email_missing_error":"Please enter a valid email.","name_missing_error":"Please enter a name.","custom_field_required_error":"A required field is empty.","note_acceptance_error":"Please accept our terms.","honeypot_error":"Your submission has been flagged as potential spam.","effects":"MOfadeInLeftBig","ga_active":true,"device_targeting_hide_desktop":false,"device_targeting_hide_tablet":false,"device_targeting_hide_mobile":false};</script><style id="mo-optin-form-stylesheet" type="text/css">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</style><div id="dxxMrRjcGP_slidein" class="mo-optin-form-wrapper mo-has-email letterBox_container" style="position: relative;background-color: #0087c0;line-height: normal;"><form method="post" class='mo-optin-form' id='dxxMrRjcGP_slidein_form' style='margin:0;'><a href='#' rel="moOptin:close" title="Close optin form" class="mo-optin-form-close-icon " style=''><img src="https://www.lkldnow.com/wp-content/plugins/mailoptin/src/libsodium/src/PremiumTemplates/assets/optin/close.png" class="letterBox_closeBtn"></a><div class="letterBox_inner"><div class="letterBox_copy"><div class="mo-optin-form-headline letterBox_header" style="color: #ffffff;font-family: 'Open Sans', Helvetica, Arial, sans-serif;">Keep Up with Lakeland.</div><div class="mo-optin-form-description letterBox_description" style="color: #ffffff;font-family: 'Open Sans', Helvetica, Arial, sans-serif;"><p style="text-align: center;"><strong>We'll send you an email on Thursdays to let you know what's happened so far this week and what's coming up for the weekend.</strong></p></div></div></div><div class="letterBox_form"><div class="mo-optin-fields-wrapper" style=""><div class="letterBox_field_wrapper"><input id="dxxMrRjcGP_slidein_name_field" class="mo-optin-field mo-optin-form-name-field letterBox_form_field" style='color: #444444;background-color: #ffffff;height: auto;font-family: Open Sans;display: none;' type="text" placeholder="Enter your name here..." name="mo-name" autocomplete="on" value=""> <input id="dxxMrRjcGP_slidein_email_field" class="mo-optin-field mo-optin-form-email-field letterBox_form_field" style="color: #444444;background-color: #ffffff;height: auto;font-family: Open Sans;" type="email" placeholder="Your Email Address:" name="mo-email" autocomplete="on" value=""> <div class="mo-optin-form-note letterbox_note" style="color: #ffffff;font-family: Raleway, Helvetica, Arial, sans-serif;"><span class="mo-note-content">We promise not to spam you. You can unsubscribe at any time.</span></div></div><div class="mo-optin-error " style=''>Invalid email address</div><input id="dxxMrRjcGP_slidein_submit_button" class="mo-optin-form-submit-button letterBox_submitButton" style="background: #ecab4a;color: #ffffff;height: auto;text-shadow: none;font-family: 'Open Sans', Helvetica, Arial, sans-serif;" type="submit" value="SIGN ME UP!"> </div><input id="dxxMrRjcGP_slidein_cta_button" class="mo-optin-form-cta-button letterBox_submitButton" style="background: #1b1bea;color: #ffffff;height: auto;text-shadow: none;font-family: Raleway, Helvetica, Arial, sans-serif;display: none;" type="submit" value="Take Action Now!"> </div><input id='dxxMrRjcGP_slidein_honeypot_email_field' type='text' name='mo-hp-email' value='' style='display:none'/><input id="dxxMrRjcGP_slidein_honeypot_website_field" type="text" name="mo-hp-website" value="" style="display:none"/></form><div class='mo-optin-spinner' style='display:none'></div><div class="mo-optin-success-msg" style="display:none">Thanks for subscribing!</div></div></div><input id="dxxMrRjcGP_slidein_honeypot_timestamp" type="hidden" name="mo-timestamp" value="1651621067" style="display:none"/></div><!-- / MailOptin WordPress plugin. -->
<script type='text/javascript'>jQuery(function(){if(typeof WebFont!=='undefined'){WebFont.load({google: {families: ['Open Sans:400,700','Raleway:400,700',]}});}});</script>
</body>
</html>